summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorGiovanni Biscuolo <g@xelera.eu>2021-08-12 18:09:02 +0200
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commit05effbbfc2fc6223aafacf8a3cb2b2d970b6bb66 (patch)
treef19d1be80b2485635fe7f8d902f498dec18f1b53 /gnu/packages/android.scm
parentef9dc9efa49a1db600805f3fbcd2dbfbabfb4ea4 (diff)
downloadguix-patches-05effbbfc2fc6223aafacf8a3cb2b2d970b6bb66.tar
guix-patches-05effbbfc2fc6223aafacf8a3cb2b2d970b6bb66.tar.gz
gnu: adb: Make compatible with OpenSSL 1.1.
OpenSSL version 1.1 brought some API changes which broke the build here, fix that by accessing rsa->n (and e) directly, using RSA_get0_key instead. * gnu/packages/patches/adb-libssl_11-compatibility.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/android.scm (android-platform-system-core)[origin]: Use it. (adb)[inputs]: Replace openssl-1.0 with openssl.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index eb538f6540..99c283dfaf 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -148,6 +148,7 @@ use their packages mostly unmodified in our Android NDK build system.")
"libutils-remove-damaging-includes.patch"
"libutils-add-includes.patch"
"adb-add-libraries.patch"
+ "adb-libssl_11-compatibility.patch"
"libziparchive-add-includes.patch"))))
(define (android-platform-system-extras version)
@@ -388,7 +389,7 @@ various Android core host applications.")
`(("android-libbase" ,android-libbase)
("android-libcutils" ,android-libcutils)
("android-liblog" ,android-liblog)
- ("openssl" ,openssl-1.0)))
+ ("openssl" ,openssl)))
(home-page "https://developer.android.com/studio/command-line/adb.html")
(synopsis "Android Debug Bridge")
(description