summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-30 04:27:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-30 04:28:59 +0100
commitfaefa2eda302722a61aed8c666c08864729604f2 (patch)
tree4cf782e6299588ce2c98eb5c3efb37b0a70e49d2 /gnu/packages/algebra.scm
parentc10f6c5ab481e81fd9882126b3768fede1a00dc1 (diff)
downloadguix-patches-faefa2eda302722a61aed8c666c08864729604f2.tar
guix-patches-faefa2eda302722a61aed8c666c08864729604f2.tar.gz
gnu: arb: Update to 2.17.0.
* gnu/packages/algebra.scm (arb): Update to 2.17.0. [home-page]: Replace with a working one.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 828a0fc748..6a9784f551 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -483,7 +483,7 @@ fast arithmetic.")
(define-public arb
(package
(name "arb")
- (version "2.16.0")
+ (version "2.17.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -492,7 +492,7 @@ fast arithmetic.")
(file-name (git-file-name name version))
(sha256
(base32
- "0478671wfwy3gl26sbxh1jq1ih36z4k72waa8y2y2lvn649gb7cd"))))
+ "05lpy3hkl5f8ik19aw40cqydrb932xaf2n8hbq9ib5dnk7f010p1"))))
(build-system gnu-build-system)
(propagated-inputs
`(("flint" ,flint))) ; flint.h is included by arf.h
@@ -508,8 +508,8 @@ fast arithmetic.")
(flint (assoc-ref inputs "flint"))
(gmp (assoc-ref inputs "gmp"))
(mpfr (assoc-ref inputs "mpfr")))
- ;; do not pass "--enable-fast-install", which makes the
- ;; homebrew configure process fail
+ ;; Do not pass "--enable-fast-install", which makes the
+ ;; homebrew configure process fail.
(invoke "./configure"
(string-append "--prefix=" out)
(string-append "--with-flint=" flint)
@@ -522,7 +522,7 @@ arithmetic. It supports efficient high-precision computation with
polynomials, power series, matrices and special functions over the
real and complex numbers, with automatic, rigorous error control.")
(license license:lgpl2.1+)
- (home-page "http://fredrikj.net/arb/")))
+ (home-page "http://arblib.org")))
(define-public python-flint
(package