summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-29 21:20:47 -0400
committerMark H Weaver <mhw@netris.org>2018-05-29 21:20:47 -0400
commitc0d7c1244a031c94062762db991b7ba7dc34b583 (patch)
treef50419fa9233fb13e3cfd0706f78bdfc13e16572 /gnu/packages/algebra.scm
parente5bbfc7df0a99faa1bb1cf28114363205c166cef (diff)
parentf274f0774dc5099eb043e0fb73e4ba75802f5cce (diff)
downloadguix-patches-c0d7c1244a031c94062762db991b7ba7dc34b583.tar
guix-patches-c0d7c1244a031c94062762db991b7ba7dc34b583.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 806dc45a24..816f013655 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -714,9 +714,10 @@ Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
;; but maintainers say it's a known issue and it's unsupported
;; anyway, so just skip them.
'(begin
+ (substitute* "unsupported/CMakeLists.txt"
+ (("add_subdirectory\\(test.*")
+ "# Do not build the tests for unsupported features.\n"))
(substitute* "CMakeLists.txt"
- (("add_subdirectory\\(unsupported\\)")
- "# Do not build the tests for unsupported features.\n")
;; Work around
;; <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
(("\"include/eigen3\"")