summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2020-08-20 19:23:03 +0200
committerAndreas Enge <andreas@enge.fr>2020-08-20 19:23:03 +0200
commitb9ef00258ca7964f0fae50b84ff5c1f3bb89556e (patch)
treeef62e2add5607ae5a6246e9563077096fafde1d4 /gnu/packages/algebra.scm
parentd9461f688cefcaa5e3ffd99b7600d727c712e176 (diff)
downloadguix-patches-b9ef00258ca7964f0fae50b84ff5c1f3bb89556e.tar
guix-patches-b9ef00258ca7964f0fae50b84ff5c1f3bb89556e.tar.gz
gnu: fplll: Update to 5.3.2.
* gnu/packages/algebra.scm (fplll): Update to 5.3.2.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 63891aecdf..58c3c9fb88 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -151,7 +151,12 @@ line applications.")
(define-public fplll
(package
(name "fplll")
- (version "5.2.1")
+ ;; The most recent version 5.3.3 fails in the configure phase:
+ ;; ./configure: line 12956: syntax error near unexpected token `LIBQD,'
+ ;; ./configure: line 12956: ` PKG_CHECK_MODULES(LIBQD, qd, have_libqd="yes",'
+ ;; The error disappears when adding qd as an input; but this is
+ ;; supposed to be an optional input.
+ (version "5.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -160,7 +165,7 @@ line applications.")
(file-name (git-file-name name version))
(sha256
(base32
- "015qmrd7nfaysbv1hbwiprz9g6hnww1y1z1xw8f43ysb7k1b5nbg"))))
+ "00iyz218ywspizjiimrjdcqvdqmrsb2367zyy3vkmypnf9i9l680"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)