summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 15:59:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:47 +0100
commit9774fac480e694806d23bccbc31feda56fa0aef4 (patch)
treee3e2ff1d82efe94c885e2e5a13cd8e54529f0376 /gnu/packages/algebra.scm
parent6aa54e23daba46b0c3aca0ec232fe7ad531df62e (diff)
downloadguix-patches-9774fac480e694806d23bccbc31feda56fa0aef4.tar
guix-patches-9774fac480e694806d23bccbc31feda56fa0aef4.tar.gz
gnu: kiss-fft-for-extempore: Fetch sources from git.
* gnu/packages/algebra.scm (kiss-fft-for-extempore)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 1f1c7be052..60d99423b2 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -568,13 +568,14 @@ syntax is similar to that of C, so basic usage is familiar. It also includes
(name "kiss-fft-for-extempore")
(version "1.3.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/extemporelang/kiss_fft/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/extemporelang/kiss_fft.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0hkp9l6l4c92fb1l2sh6a6zv1hynpvb2s4d03vd8vxyvybc0l4pv"))))
+ "0jasbmqy4wkqrqx3w64s1dfmj34875xmsl72mb26aa4hpyn14bi2"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; no tests included
;; Extempore refuses to build on architectures other than x86_64