summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-19 18:54:52 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-19 18:56:55 +0200
commit7c5f623192d4d316ce62270cbdb9daa7848c323d (patch)
treeec2e930f7d1af907d53f8bf5b46538d2eaa523cb /gnu/packages/algebra.scm
parent01822e3ebf24031d6438fc4e7ad3a869ea12fdf4 (diff)
downloadguix-patches-7c5f623192d4d316ce62270cbdb9daa7848c323d.tar
guix-patches-7c5f623192d4d316ce62270cbdb9daa7848c323d.tar.gz
gnu: Add gf2x.
* gnu/packages/algebra.scm (gf2x): New variable.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 86c0a42758..fefe712a33 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -93,6 +93,27 @@ multiplication routines such as Toom–Cook and the FFT.")
(license license:lgpl3+)
(home-page "http://mpfrcx.multiprecision.org/")))
+(define-public gf2x
+ (package
+ (name "gf2x")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gforge.inria.fr/frs/download.php/file/36934/gf2x-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0d6vh1mxskvv3bxl6byp7gxxw3zzpkldrxnyajhnl05m0gx7yhk1"))))
+ (build-system gnu-build-system)
+ (synopsis "Arithmetic of polynomials over binary finite fields")
+ (description
+ "The gf2x library provides arithmetic of polynomials over finite fields
+of characteristic 2. It implements the multiplication, squaring and
+greatest common divisor operations.")
+ (license license:gpl3+)
+ (home-page "https://gforge.inria.fr/projects/gf2x/")))
+
(define-public cm
(package
(name "cm")