summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-20 11:07:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-20 11:07:12 +0200
commit25cbaa9e705a4d8cde39b5a83c4c54114db45984 (patch)
treefbfbeba810d3e7dd853b8c3ac9e8c243e0e04a57 /gnu/packages/algebra.scm
parent1de48e8f8afec23847458c533d2fae0d69d8942a (diff)
downloadguix-patches-25cbaa9e705a4d8cde39b5a83c4c54114db45984.tar
guix-patches-25cbaa9e705a4d8cde39b5a83c4c54114db45984.tar.gz
gnu: Add python-fpylll.
* gnu/packages/algebra.scm (python-fpylll): New variable.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8d7c9709d1..22d458d36d 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -189,6 +189,38 @@ that computes a lattice vector closest to a given vector belonging to
the real span of the lattice.")
(license license:lgpl2.1+)))
+(define-public python-fpylll
+ (package
+ (name "python-fpylll")
+ (version "0.4.1")
+ (source
+ (origin
+ ;; Pypi contains and older release, so we use a tagged release from
+ ;; Github instead.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fplll/fpylll.git")
+ (commit (string-append version "dev"))))
+ (sha256
+ (base32
+ "01x2sqdv0sbjj4g4waj0hj4rcn4bq7h17442xaqwbznym9azmn9w"))))
+ (build-system python-build-system)
+ (inputs
+ `(("fplll" ,fplll)
+ ("gmp" ,gmp)
+ ("mpfr" ,mpfr)
+ ("pari-gp" ,pari-gp)))
+ (propagated-inputs
+ `(("cysignals" ,python-cysignals)
+ ("cython" ,python-cython)
+ ("flake8" ,python-flake8)
+ ("numpy" ,python-numpy)
+ ("pytest" ,python-pytest)))
+ (home-page "https://github.com/fplll/fpylll")
+ (synopsis "Python interface for fplll")
+ (description "fpylll is a Python wrapper for fplll.")
+ (license license:gpl2+)))
+
(define-public pari-gp
(package
(name "pari-gp")