summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
committerMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
commit1640f16e7888291227d11647dbb5f83ad5d138a1 (patch)
treebf979aa4e6538b8261762cfbb80512ebb023b016 /gnu/packages/algebra.scm
parent0ff4e49a95d8a54cd5508f441b927a670d348519 (diff)
parenta4e45acdc07fc3faf2844b3658ee31ebc538bd1c (diff)
downloadguix-patches-1640f16e7888291227d11647dbb5f83ad5d138a1.tar
guix-patches-1640f16e7888291227d11647dbb5f83ad5d138a1.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index a794c4c6a8..61981f6c7b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -60,15 +60,15 @@
(define-public mpfrcx
(package
(name "mpfrcx")
- (version "0.4.2")
+ (version "0.5")
(source (origin
(method url-fetch)
(uri (string-append
- "http://www.multiprecision.org/mpfrcx/download/mpfrcx-"
+ "http://www.multiprecision.org/downloads/mpfrcx-"
version ".tar.gz"))
(sha256
(base32
- "0grw66b255r574lvll1bqccm5myj2m8ajzsjaygcyq9zjnnbnhhy"))))
+ "1s968480ymv6w0rnvfp9mxvx98hvi29fkvw8nk4ggzc6azxgwybs"))))
(build-system gnu-build-system)
(propagated-inputs
`(("gmp" ,gmp)
@@ -82,7 +82,7 @@ on the rounding. For the time being, only the few functions needed to
implement the floating point approach to complex multiplication are
implemented. On the other hand, these comprise asymptotically fast
multiplication routines such as Toom–Cook and the FFT.")
- (license license:lgpl2.1+)
+ (license license:lgpl3+)
(home-page "http://mpfrcx.multiprecision.org/")))
(define-public cm