summaryrefslogtreecommitdiff
path: root/gnu/packages/aidc.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-01-30 14:52:29 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 20:13:09 -0500
commitd41e25c05825d062a8237c9e1186194d6bab3484 (patch)
tree8c99abcf15b12ba99e71685a23756ba2e7cd846f /gnu/packages/aidc.scm
parent3dbab6824de2a733420929d269deb2e746064e09 (diff)
downloadguix-patches-d41e25c05825d062a8237c9e1186194d6bab3484.tar
guix-patches-d41e25c05825d062a8237c9e1186194d6bab3484.tar.gz
gnu: Add qrcodegen-cpp.
* gnu/packages/aidc.scm (qrcodegen-cpp): New variable. * gnu/packages/patches/qrcodegen-cpp-make-install.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/aidc.scm')
-rw-r--r--gnu/packages/aidc.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 77db0ac9fc..b68f2137be 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -154,3 +155,41 @@ For application developers, language bindings are included for C, C++ and
Python as well as GUI widgets for GTK and Qt.")
(home-page "https://github.com/mchehab/zbar")
(license license:lgpl2.1+)))
+
+(define-public qrcodegen-cpp
+ ;; Currently this project's installation mechanism only exists as a GitHub
+ ;; pull request, so we build from a recent commit that the proposed patch
+ ;; applies to.
+ (let ((commit "6ea933f1596d818bd21e9a6b8d2e851fb8b4bcf1")
+ (revision "0"))
+ (package
+ (name "qrcodegen-cpp")
+ (version (git-version "1.5.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nayuki/QR-Code-generator.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (patches (search-patches "qrcodegen-cpp-make-install.patch"))
+ (sha256
+ (base32
+ "19fcwqmfk2n9p2n01dv2j4x2y2mqip0j1wbmfbxjp34rqkjwcwxm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No ./configure script
+ ;; Only build the C++ variant.
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "cpp")
+ #t)))))
+ (synopsis "QR Code generator library")
+ (description "qrcodegen-cpp is a QR code generator library in C++. The
+project also offers Java, Javascript, Python, C, and Rust implementations.")
+ (home-page "https://www.nayuki.io/page/qr-code-generator-library")
+ (license license:expat))))