summaryrefslogtreecommitdiff
path: root/gnu/packages/aidc.scm
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-05-29 13:40:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-31 23:21:02 +0200
commit7293e3dba107abe416fde72c25dc351de3cfeef9 (patch)
tree40473456901ff9079c8bfd53d677a4fb14425341 /gnu/packages/aidc.scm
parent2177d9222f8c228fe5cd4e9c98d96f97e9601b86 (diff)
downloadguix-patches-7293e3dba107abe416fde72c25dc351de3cfeef9.tar
guix-patches-7293e3dba107abe416fde72c25dc351de3cfeef9.tar.gz
gnu: Add zbar.
* gnu/packages/aidc.scm (zbar): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/aidc.scm')
-rw-r--r--gnu/packages/aidc.scm55
1 files changed, 54 insertions, 1 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index afcb33ad6d..61d3331c97 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,8 +27,15 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (gnu packages autotools)
- #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages video)
#:use-module (guix build-system gnu))
@@ -102,3 +110,48 @@ characters, and is highly robust.")
barcodes of the modern ECC200 variety. libdmtx is a shared library, allowing
C/C++ programs to use its capabilities without restrictions or overhead.")
(license license:bsd-3)))
+
+(define-public zbar
+ (package
+ (name "zbar")
+ (version "0.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://linuxtv.org/downloads/zbar/zbar-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0bmd93a15qpgbsq9c9j33qms18rdrgz6gbc48zi6z9w5pvrvi7z9"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list "--with-gtk=auto"
+ "--with-python=auto"
+ (string-append "--with-dbusconfdir="
+ (assoc-ref %outputs "out")
+ "/etc")
+ "CXXFLAGS=-std=c++11")))
+ (native-inputs
+ `(("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("imagemagick" ,imagemagick)
+ ("libjpeg" ,libjpeg-turbo)
+ ("python" ,python)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("v4l-utils" ,v4l-utils)))
+ (synopsis "Bar code reader")
+ (description
+ "ZBar can read barcodes from various sources, such as video streams,
+image files, and raw intensity sensors. It supports EAN-13/UPC-A, UPC-E,
+EAN-8, Code 128, Code 93, Code 39, Codabar, Interleaved 2 of 5, QR Code and SQ
+Code. Included with the library are basic applications for decoding captured
+bar code images and using a video device (e.g. webcam) as a bar code scanner.
+For application developers, language bindings are included for C, C++ and
+Python as well as GUI widgets for GTK and Qt.")
+ (home-page "https://github.com/mchehab/zbar")
+ (license license:lgpl2.1+)))