summaryrefslogtreecommitdiff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-16 09:41:37 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:50 -0500
commit27109c7175656b8de3d0819e0acc0670863930c6 (patch)
tree8bc6423dc4b2152d7af916dbb3e5e401074979c8 /gnu/packages/agda.scm
parentaf16c6b0564ea992d57a6a040f0ae59e09b6bb20 (diff)
downloadguix-patches-27109c7175656b8de3d0819e0acc0670863930c6.tar
guix-patches-27109c7175656b8de3d0819e0acc0670863930c6.tar.gz
gnu: agda: Update to 2.6.0.1.
* gnu/packages/agda.scm (agda): Update to 2.6.0.1. [inputs]: Remove 'ghc-parallel'; add 'ghc-aeson' and 'ghc-exceptions'.
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 931f1e8ef7..60944ddb04 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -37,7 +37,7 @@
(define-public agda
(package
(name "agda")
- (version "2.5.4.2")
+ (version "2.6.0.1")
(source
(origin
(method url-fetch)
@@ -46,10 +46,11 @@
version ".tar.gz"))
(sha256
(base32
- "07wvawpfjhx3gw2w53v27ncv1bl0kkx08wkm6wzxldbslkcasign"))))
+ "1s600ry1qwizr3ynyj05rvlx7jdcw9a1viyc0ycjamm5sjf8mf3v"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-alex" ,ghc-alex)
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-alex" ,ghc-alex)
("ghc-async" ,ghc-async)
("ghc-blaze-html" ,ghc-blaze-html)
("ghc-boxes" ,ghc-boxes)
@@ -57,6 +58,7 @@
("ghc-edisoncore" ,ghc-edisoncore)
("ghc-edit-distance" ,ghc-edit-distance)
("ghc-equivalence" ,ghc-equivalence)
+ ("ghc-exceptions" ,ghc-exceptions)
("ghc-filemanip" ,ghc-filemanip)
("ghc-geniplate-mirror" ,ghc-geniplate-mirror)
("ghc-gitrev" ,ghc-gitrev)
@@ -66,7 +68,6 @@
("ghc-ieee754" ,ghc-ieee754)
("ghc-murmur-hash" ,ghc-murmur-hash)
("ghc-uri-encode" ,ghc-uri-encode)
- ("ghc-parallel" ,ghc-parallel)
("ghc-regex-tdfa" ,ghc-regex-tdfa)
("ghc-strict" ,ghc-strict)
("ghc-unordered-containers" ,ghc-unordered-containers)