summaryrefslogtreecommitdiff
path: root/gnu/packages/adns.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 16:51:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 16:51:16 +0200
commitc1cb85bf765e71aef674a132df644f4edf06a8e1 (patch)
tree2f4d9422a5ef046460ebc7105bfcc902cd1a51fb /gnu/packages/adns.scm
parentd08482f03fb8abb529b36dfdae8e53d326b8002f (diff)
downloadguix-patches-c1cb85bf765e71aef674a132df644f4edf06a8e1.tar
guix-patches-c1cb85bf765e71aef674a132df644f4edf06a8e1.tar.gz
gnu: gRPC: Re-add custom c-ares variant.
Commit e8393ebe46d9ad09aceb152618db490378ba5ded updated c-ares without knowing that cmake-build-system was the most important feature of 'c-ares-next'. * gnu/packages/adns.scm (c-ares/cmake): New hidden package. * gnu/packages/machine-learning.scm (grpc)[inputs]: Change C-ARES to C-ARES/CMAKE.
Diffstat (limited to 'gnu/packages/adns.scm')
-rw-r--r--gnu/packages/adns.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/adns.scm b/gnu/packages/adns.scm
index f6df825e7c..541612d41a 100644
--- a/gnu/packages/adns.scm
+++ b/gnu/packages/adns.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,3 +83,17 @@ queries without blocking, or need to perform multiple DNS queries in parallel.
The primary examples of such applications are servers which communicate with
multiple clients and programs with graphical user interfaces.")
(license (x11-style "https://c-ares.haxx.se/license.html"))))
+
+;; gRPC requires a c-ares built with CMake in order to get the .cmake modules.
+;; We can not build c-ares itself with CMake because that would introduce a
+;; circular dependency through nghttp2.
+;; XXX: It would be nice if we could extract the modules somehow and make them
+;; work with the "normal" c-ares package instead of building a whole new library.
+(define-public c-ares/cmake
+ (hidden-package
+ (package
+ (inherit c-ares)
+ (build-system cmake-build-system)
+ (arguments
+ `(;; XXX: Tests require name resolution (the normal variant runs no tests).
+ #:tests? #f)))))