summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-22 23:19:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-22 23:28:47 -0500
commitf1f1b8b4e69055313fc0281528d31b5afa42b861 (patch)
treead2c8a1c7aa12fc5ea208a1b95f2d570309644b8 /gnu/packages/admin.scm
parentb04d2724f7434401b4311eee4ceb0e6d70033f83 (diff)
downloadguix-patches-f1f1b8b4e69055313fc0281528d31b5afa42b861.tar
guix-patches-f1f1b8b4e69055313fc0281528d31b5afa42b861.tar.gz
gnu: testdisk: Relocate and improve description.
This is the result of attempting to package 'photorec', only to realize it's part of testdisk, which we already had in the first place. * gnu/packages/admin.scm (testdisk): Move to... * gnu/packages/disk.scm (testdisk): ... here. [description]: Expound, and add a description section about the included PhotoRec tool.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 7da8a29306..d232013ef9 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2342,34 +2342,6 @@ characters (such as \"$\") get replaced with \"_\". ISO 8859-1 (Latin-1)
characters can be replaced as well, as can UTF-8 characters.")
(license license:bsd-3)))
-(define-public testdisk
- (package
- (name "testdisk")
- (version "7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.cgsecurity.org/testdisk-"
- version ".tar.bz2"))
- (sha256
- (base32
- "1zlh44w67py416hkvw6nrfmjickc2d43v51vcli5p374d5sw84ql"))))
- (build-system gnu-build-system)
- (inputs
- (list ntfs-3g
- `(,util-linux "lib")
- openssl
- ;; FIXME: add reiserfs.
- zlib
- e2fsprogs
- libjpeg-turbo
- ncurses))
- (home-page "https://www.cgsecurity.org/wiki/TestDisk")
- (synopsis "Data recovery tool")
- (description
- "TestDisk is a program for data recovery, primarily designed to help
-recover lost partitions and/or make non-booting disks bootable again.")
- (license license:gpl2+)))
-
(define-public tree
(package
(name "tree")