summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-05-15 13:36:45 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-15 14:19:39 +0200
commitef9652ef4e6556fd85bc84dca53dfe97f518b060 (patch)
tree46045791ddaaa5d933144fd3c8ff5a689fa8b13f /gnu/packages/admin.scm
parentc7c9370dd7c5d2dfc038cbbec802f0f001af158f (diff)
downloadguix-patches-ef9652ef4e6556fd85bc84dca53dfe97f518b060.tar
guix-patches-ef9652ef4e6556fd85bc84dca53dfe97f518b060.tar.gz
gnu: rottlog: Fix aarch64 cross-compilation.
* gnu/packages/admin.scm (rottlog)[arguments]: Add a 'fix-configure phase to replace outdated config.sub and config.guess, without aarch64 support, [native-inputs]: add "automake".
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6083691e19..9822ba8a9b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1229,7 +1229,7 @@ at once based on a Perl regular expression.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags (list "ROTT_ETCDIR=/etc/rottlog" ;rc file location
+ `(#:configure-flags (list "ROTT_ETCDIR=/etc/rottlog" ;rc file location
"--localstatedir=/var")
;; Install example config files in OUT/etc.
@@ -1243,6 +1243,20 @@ at once based on a Perl regular expression.")
(substitute* "rc/rc"
(("/usr/sbin/sendmail") "sendmail"))
#t))
+ (add-after 'unpack 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (for-each (lambda (file)
+ (install-file
+ (string-append
+ (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub" "config.guess"))
+ #t))
(add-after 'build 'set-packdir
(lambda _
;; Set a default location for archived logs.
@@ -1263,6 +1277,7 @@ at once based on a Perl regular expression.")
(lambda _
(invoke "make" "install-info"))))))
(native-inputs `(("texinfo" ,texinfo)
+ ("automake" ,automake)
("util-linux" ,util-linux))) ; for 'cal'
(home-page "https://www.gnu.org/software/rottlog/")
(synopsis "Log rotation and management")