summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
commitebb7cf9e21060105d9950dd5142c0eb918083666 (patch)
tree36c1607b80d92e27fb9d09029d1d3b57a1fd5065 /gnu/packages/admin.scm
parent0b870f7915f5da43758753fd088a22033936dc50 (diff)
parentc2d7e800e6788277bc56f31d5836f9d507dc1506 (diff)
downloadguix-patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar
guix-patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm77
1 files changed, 56 insertions, 21 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 02fdb453b6..6fb342dfee 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015, 2016, 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018 Eric Bavier <bavier@member.fsf.org>
@@ -24,7 +24,7 @@
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
-;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019,2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
@@ -196,14 +196,14 @@ and provides a \"top-like\" mode (monitoring).")
(define-public shepherd
(package
(name "shepherd")
- (version "0.6.1")
+ (version "0.7.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/shepherd/shepherd-"
version ".tar.gz"))
(sha256
(base32
- "1xn6mb5bh8bpfgdrh09ja31jk0ln7bmxbbf0vjcqxkkixs2wl6sk"))))
+ "07j3vd0y8zab2nwbrwj0ahrfif1ldm5sjssn7m3dw4s307fsrfzx"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--localstatedir=/var")))
@@ -228,6 +228,16 @@ interface and is based on GNU Guile.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/shepherd/")))
+(define-public guile3.0-shepherd
+ (package
+ (inherit shepherd)
+ (name "guile3.0-shepherd")
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("guile" ,guile-next)))
+ (inputs
+ `(("guile" ,guile-next)))))
+
(define-public cloud-utils
(package
(name "cloud-utils")
@@ -405,7 +415,7 @@ application (for console or X terminals) and requires ncurses.")
(("\"/bin/sh\"")
(string-append "\"" bash "/bin/sh\"")))
#t))))))
- (home-page "https://www.gnu.org/software/pies/")
+ (home-page "https://www.gnu.org.ua/software/pies/")
(synopsis "Program invocation and execution supervisor")
(description
"GNU pies is a program that supervises the invocation and execution of
@@ -1571,7 +1581,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
(define-public acpica
(package
(name "acpica")
- (version "20200110")
+ (version "20200214")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1579,7 +1589,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
version ".tar.gz"))
(sha256
(base32
- "1hb4g6r7w8s4bhlkk36fmb4qxghnrwvad7f18cpn6zz0b4sjs7za"))))
+ "0jdasziq184l3iqyp5vhrsbi6g89n10wr0ssliiz0xi3dqwsxcqk"))))
(build-system gnu-build-system)
(native-inputs `(("flex" ,flex)
("bison" ,bison)))
@@ -1774,7 +1784,7 @@ environment variable is set and output is to tty.")
(string-append "SHELL=" bash "/bin/sh")))
#t))))))
- (home-page "https://www.gnu.org/software/direvent/")
+ (home-page "https://www.gnu.org.ua/software/direvent/")
(synopsis "Daemon to monitor directories for events such as file removal")
(description
"A daemon that monitors directories for events, such as creating,
@@ -1905,13 +1915,13 @@ of supported upstream metrics systems simultaneously.")
(define-public ansible
(package
(name "ansible")
- (version "2.8.5")
+ (version "2.9.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "11k94ifp42psivzx147xwbmq1ak7qnjdgkb6c1xz53nfapkh754f"))))
+ (base32 "19fav6rs58zdc3gfhh1lxhki36jn4252183rrd769sv46b9m1bji"))))
(build-system python-build-system)
(native-inputs
`(("python-bcrypt" ,python-bcrypt)
@@ -2230,7 +2240,7 @@ displays a table of current bandwidth usage by pairs of hosts.")
(define-public munge
(package
(name "munge")
- (version "0.5.13")
+ (version "0.5.14")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/dun/munge/releases/"
@@ -2238,20 +2248,45 @@ displays a table of current bandwidth usage by pairs of hosts.")
version ".tar.xz"))
(sha256
(base32
- "1nj486bbg1adfg298zck96vgx57kchcypc1zdz1n7w540vyksxcr"))
+ "0h06sghb4rqvv1ywyd6mzsmbcgh712v6ygrff0gzm440y4ca41k6"))
(modules '((guix build utils)))
(snippet
'(begin
;; Don't insist on write access to /var.
(substitute* "src/etc/Makefile.in"
(("\\$\\(INSTALL\\)(.*)localstatedir" _ middle)
- (string-append "-$(INSTALL)" middle "localstatedir")))
+ (string-append "-$(INSTALL)" middle "localstatedir"))
+ (("\\$\\(MKDIR_P\\) .*(local|run)statedir.*")
+ ""))
#t))))
(inputs
`(("openssl" ,openssl)
("libgcrypt" ,libgcrypt)))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--localstatedir=/var")))
+ (arguments
+ '(#:configure-flags
+ (list "--localstatedir=/var"
+ (string-append "--with-pkgconfigdir="
+ (assoc-ref %outputs "out") "/lib/pkgconfig"))
+ #:phases
+ (modify-phases %standard-phases
+ ;; XXX Many test series fail. Some might be fixable, others do no-no
+ ;; things like invoking ‘sudo’.
+ (add-after 'unpack 'skip-failing-tests
+ (lambda _
+ (for-each (lambda (test)
+ (substitute* "t/Makefile.in"
+ (((string-append test "\\.t ")) "")))
+ (list "0100-munged-lock"
+ "0010-basic"
+ "0011-munged-cmdline"
+ "0012-munge-cmdline"
+ "0013-unmunge-cmdline"
+ "0101-munged-security-socket"
+ "0102-munged-security-keyfile"
+ "0103-munged-security-logfile"
+ "0110-munged-origin-addr"))
+ #t)))))
(home-page "https://dun.github.io/munge/")
(synopsis "Cluster computing authentication service")
(description
@@ -2500,7 +2535,7 @@ a new command using the matched rule, and runs it.")
(setenv "prefix" (assoc-ref outputs "out"))
#t)))
#:make-flags (list "--environment-overrides")))
- (home-page "https://www.gentoo.com/di/")
+ (home-page "https://gentoo.com/di/")
(synopsis "Advanced df like disk information utility")
(description
"@code{di} is a disk information utility, displaying everything that your
@@ -2840,14 +2875,14 @@ Intel DRM Driver.")
(define-public fabric
(package
(name "fabric")
- (version "1.14.0")
+ (version "1.14.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Fabric" version))
(sha256
(base32
- "13r0b0hllgf8j9rh6x1knmbgvingbdmx046aazv6vck2ll120mw1"))))
+ "1a3ndlpdw6bhn8fcw1jgznl117a8pnr84az9rb5fwnrypf1ph2b6"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2 ; Python 2 only
@@ -2871,7 +2906,7 @@ Intel DRM Driver.")
("python2-bcrypt" ,python2-bcrypt)))
(propagated-inputs
`(("python2-paramiko" ,python2-paramiko)))
- (home-page "http://fabfile.org")
+ (home-page "https://www.fabfile.org/")
(synopsis "Simple Pythonic remote execution and deployment tool")
(description
"Fabric is designed to upload files and run shell commands on a number of
@@ -3320,14 +3355,14 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
(define-public python-pyudev
(package
(name "python-pyudev")
- (version "0.21.0")
+ (version "0.22.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyudev" version))
(sha256
(base32
- "0arz0dqp75sszsmgm6vhg92n1lsx91ihddx3m944f4ah0487ljq9"))))
+ "0xmj6l08iih2js9skjqpv4w7y0dhxyg91zmrs6v5aa65gbmipfv9"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Tests require /sys
@@ -3353,7 +3388,7 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
("python-mock" ,python-mock)
("python-pytest" ,python-pytest)
("python-sphinx" ,python-sphinx)))
- (home-page "http://pyudev.readthedocs.org/")
+ (home-page "https://pyudev.readthedocs.io/")
(synopsis "Python udev binding")
(description "This package provides @code{udev} bindings for Python.")
(license license:lgpl2.1)))