summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-01-30 10:58:17 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-30 10:58:17 +0100
commite41f8923f98c97823836f3562ba3f0aa0c855e11 (patch)
treee1f9366bec65370b66d242c3ebeece4a2d94725d /gnu/packages/admin.scm
parent784048c27b90e32814f6d06363f94fb3f9bf0a6d (diff)
downloadguix-patches-e41f8923f98c97823836f3562ba3f0aa0c855e11.tar
guix-patches-e41f8923f98c97823836f3562ba3f0aa0c855e11.tar.gz
gnu: Add nq.
* gnu/packages/admin.scm (nq): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c470d9288f..538e8d3eb4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -4346,3 +4346,32 @@ This program allows you to view and manipulate this EEPROM list.")
the XMODEM/YMODEM/ZMODEM file transfer protocols.")
(home-page "https://ohse.de/uwe/software/lrzsz.html")
(license license:gpl2+)))
+
+(define-public nq
+ (package
+ (name "nq")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/leahneukirchen/nq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1db96ykz35r273jyhf7cdknqk4p2jj9l8gbz7pjy1hq4pb6ffk99"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Unix command line queue utility")
+ (description
+ "@code{nq} can create very lightweight job queue systems which require no
+setup, maintenance, supervision, or any long-running processes.")
+ (home-page "https://github.com/leahneukirchen/nq")
+ (license license:public-domain)))