summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2022-01-10 14:49:15 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2022-01-10 15:29:23 +0100
commitc78f916a46de8fcca15e9d65b9190534ba2cecd8 (patch)
tree7523d041eb643dfe561cd6b04b020f46f0a750fa /gnu/packages/admin.scm
parent0976e92a0f014a7cf4d126b58f334103c814d648 (diff)
downloadguix-patches-c78f916a46de8fcca15e9d65b9190534ba2cecd8.tar
guix-patches-c78f916a46de8fcca15e9d65b9190534ba2cecd8.tar.gz
gnu: Add xfel.
* gnu/packages/admin.scm (xfel): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 918a07f014..7bd27bb725 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3537,6 +3537,43 @@ in order to be able to find it.
@end enumerate")
(license license:gpl2+)))
+(define-public xfel
+ (package
+ (name "xfel")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xboot/xfel.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0r4j63vh6279fj1yh71h08d1av3nc0majlad5yh6admsxiig101m"))
+ (file-name (git-file-name name version))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list libusb))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests exist
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-installation-target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("/usr/local") out)
+ (("/usr") out)
+ (("/etc/udev/rules.d")
+ (string-append out "/lib/udev/rules.d"))))))
+ (delete 'configure))))
+ (home-page "https://github.com/xboot/xfel")
+ (synopsis "Remote debugging tool for Allwinner D1 computers")
+ (description "This package contains a debugging tool for Allwinner D1
+devices (connects via USB OTG).")
+ (license license:expat)))
+
(define-public sedsed
(package
(name "sedsed")