summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authormethuselah-0 <david.larsson@selfhosted.xyz>2021-04-08 21:26:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-12 12:51:11 +0200
commitb9986cac3ed33cfa9455fc8a27738d2342d3aa45 (patch)
treea05b7549c6afd8a88f6bf34e13be6f40c9c7ff53 /gnu/packages/admin.scm
parentf67663d6694c20eefe006dd8910008defbbcb2d3 (diff)
downloadguix-patches-b9986cac3ed33cfa9455fc8a27738d2342d3aa45.tar
guix-patches-b9986cac3ed33cfa9455fc8a27738d2342d3aa45.tar.gz
gnu: Add prips.
gnu/packages/admin.scm (prips): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c08f5dad27..512ac320e6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1051,6 +1052,36 @@ recursive runs on the generated subnets. (also IPv6)
@end itemize\n")
(license license:bsd-3)))
+(define-public prips
+ (package
+ (name "prips")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://devel.ringlet.net/files/sys/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1a33vbl4w603mk6mm5r3vhk87fy3dfk5wdpch0yd3ncbkg3fmvqn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target)))
+ #:test-target "test"
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "prips"
+ (string-append out "/bin"))))))))
+ (native-inputs `(("perl-test-harness" ,perl-test-harness)))
+ (synopsis "Tool that prints the IP addresses in a given range")
+ (description "Prips can be used to print all of the IP addresses in
+ a given range. This allows the enhancement of tools only work
+ on one host at a time (e.g. whois).")
+ (home-page "https://devel.ringlet.net/sysutils/prips/")
+ (license license:gpl2+)))
+
(define-public alive
(package
(name "alive")