summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-06-27 11:39:50 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-06-27 12:29:34 +0300
commitace3e549737e7bd935bebeb69b13087d8f0ccd6d (patch)
tree18239f0c3d04268cc873157c986378cdd4e54720 /gnu/packages/admin.scm
parent27fffa19c0098f9f988e4739f8f936b1cbb9d3df (diff)
downloadguix-patches-ace3e549737e7bd935bebeb69b13087d8f0ccd6d.tar
guix-patches-ace3e549737e7bd935bebeb69b13087d8f0ccd6d.tar.gz
gnu: Add jtbl.
* gnu/packages/admin.scm (jtbl): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index de2f6534f8..9212401c40 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3863,3 +3863,25 @@ It supports mounting local filesystems of any kind the normal mount utility
supports. It can also mount encrypted LUKS volumes using the password
supplied by the user when logging in.")
(license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public jtbl
+ (package
+ (name "jtbl")
+ (version "1.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kellyjonbrazil/jtbl.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zzd7rd63xva50f22d1rfja4r302aizrafarhwm67vv181swvdya"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-tabulate" ,python-tabulate)))
+ (home-page "https://github.com/kellyjonbrazil/jtbl")
+ (synopsis "Command-line tool to print JSON data as a table in the terminal")
+ (description "@code{jtbl} accepts piped JSON data from stdin and outputs a
+text table representation to stdout.")
+ (license license:expat)))