summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-06 17:23:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-06 22:15:08 +0200
commitaba98be5406eaeaf70dbd6b9b30e16d254ede9d7 (patch)
tree3c17830f91c4ddb352f4b9da71776625271e7d61 /gnu/packages/admin.scm
parentcfec1af96a19be3fef26e13900937773355ee580 (diff)
downloadguix-patches-aba98be5406eaeaf70dbd6b9b30e16d254ede9d7.tar
guix-patches-aba98be5406eaeaf70dbd6b9b30e16d254ede9d7.tar.gz
gnu: di: Cross-compile.
* gnu/packages/admin.scm (di)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2e1c4d1ada..bb93f7efb1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2758,7 +2758,7 @@ a new command using the matched rule, and runs it.")
(delete 'configure) ; no configure script
(add-before 'build 'setup-environment
(lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" "gcc")
+ (setenv "CC" ,(cc-for-target))
(setenv "prefix" (assoc-ref outputs "out"))
#t)))
#:make-flags (list "--environment-overrides")))