summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 16:51:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 21:21:10 +0200
commita91ad29d172132c99557ed86aaed7fff16c14c8f (patch)
tree9f849c6364a111d31d3a41fea6977a1d850dae12 /gnu/packages/admin.scm
parentecc7de528f7e0bcb6fcfb6f884335e358003fc9a (diff)
downloadguix-patches-a91ad29d172132c99557ed86aaed7fff16c14c8f.tar
guix-patches-a91ad29d172132c99557ed86aaed7fff16c14c8f.tar.gz
gnu: nmap: Update to 7.92.
* gnu/packages/admin.scm (nmap): Update to 7.92. [source, arguments]: Don't explicitly return #t from snippet & phases.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 69cedacd90..192bd623bb 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3025,14 +3025,14 @@ done with the @code{auditctl} utility.")
(define-public nmap
(package
(name "nmap")
- (version "7.91")
+ (version "7.92")
(source (origin
(method url-fetch)
(uri (string-append "https://nmap.org/dist/nmap-" version
".tar.bz2"))
(sha256
(base32
- "001kb5xadqswyw966k2lqi6jr6zz605jpp9w4kmm272if184pk0q"))
+ "18bifn67kz2wxkbnfwcrin2xrhc6qf4p2bvxfqb2a2vbi8pryix5"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3043,8 +3043,7 @@ done with the @code{auditctl} utility.")
"libpcap"
"libpcre"
;; Remove pre-compiled binares.
- "mswin32"))
- #t))))
+ "mswin32"))))))
(build-system gnu-build-system)
(inputs
`(("openssl" ,openssl)
@@ -3066,8 +3065,7 @@ done with the @code{auditctl} utility.")
(lambda _
(substitute* "Makefile"
;; Do not attempt to build lua.
- (("build-dnet build-lua") "build-dnet"))
- #t))
+ (("build-dnet build-lua") "build-dnet"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(define (make out . args)
@@ -3090,8 +3088,7 @@ done with the @code{auditctl} utility.")
(make ndiff "install-ndiff")
(wrap-program (string-append ndiff "/bin/ndiff")
`("PYTHONPATH" prefix
- (,(python-path ndiff)))))
- #t))
+ (,(python-path ndiff)))))))
;; These are the tests that do not require network access.
(replace 'check
(lambda _ (invoke "make"
@@ -3108,7 +3105,7 @@ tool. It is also useful for tasks such as network inventory, managing service
upgrade schedules, and monitoring host or service uptime. It also provides an
advanced netcat implementation (ncat), a utility for comparing scan
results (ndiff), and a packet generation and response analysis tool (nping).")
- ;; See <https://github.com/nmap/nmap/issues/2199#issuecomment-792048244>.
+ ;; See <https://github.com/nmap/nmap/issues/2199#issuecomment-894812634>.
;; This package uses nmap's bundled versions of libdnet and liblinear, which
;; both use a 3-clause BSD license.
(license (list license:nmap license:bsd-3))))