summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-05 10:34:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-05 11:59:49 +0200
commit9dbda847af45fe4ede75db58b748ae491916a486 (patch)
treec77f1195919cef480fdeff71aec457e4c62f8430 /gnu/packages/admin.scm
parent4d755996a7f49465490e049caf9d6952aaa12f09 (diff)
downloadguix-patches-9dbda847af45fe4ede75db58b748ae491916a486.tar
guix-patches-9dbda847af45fe4ede75db58b748ae491916a486.tar.gz
gnu: screenfetch: Use the tagged release.
* gnu/packages/admin.scm (screenfetch): Use the new 3.9.0 release tag instead of a (functionally identical) naked commit.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm103
1 files changed, 51 insertions, 52 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 98827ca303..8c550a79af 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2852,61 +2852,60 @@ you are running, what theme or icon set you are using, etc.")
(license license:expat)))
(define-public screenfetch
- (let ((commit "e7b94fc3c529b9b97f32b71fd4bc05fb1d0f5864"))
- (package
- (name "screenfetch")
- (version (git-version "3.8.0" "2" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/KittyKatt/screenFetch")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13i7dczbqwhws08zzrdraki1zkqv0qkbgx9c1r8vmg5qr9f7hfzg"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((source (assoc-ref %build-inputs "source"))
- (out (assoc-ref %outputs "out")))
- (mkdir-p (string-append out "/bin/"))
- (copy-file (string-append source "/screenfetch-dev")
- (string-append out "/bin/screenfetch"))
- (install-file (string-append source "/screenfetch.1")
- (string-append out "/man/man1/"))
- (install-file (string-append source "/COPYING")
- (string-append out "/share/doc/" ,name "-" ,version))
- (substitute* (string-append out "/bin/screenfetch")
- (("/usr/bin/env bash")
- (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash")))
- (wrap-program
+ (package
+ (name "screenfetch")
+ (version "3.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KittyKatt/screenFetch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13i7dczbqwhws08zzrdraki1zkqv0qkbgx9c1r8vmg5qr9f7hfzg"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (out (assoc-ref %outputs "out")))
+ (mkdir-p (string-append out "/bin/"))
+ (copy-file (string-append source "/screenfetch-dev")
+ (string-append out "/bin/screenfetch"))
+ (install-file (string-append source "/screenfetch.1")
+ (string-append out "/man/man1/"))
+ (install-file (string-append source "/COPYING")
+ (string-append out "/share/doc/" ,name "-" ,version))
+ (substitute* (string-append out "/bin/screenfetch")
+ (("/usr/bin/env bash")
+ (string-append (assoc-ref %build-inputs "bash")
+ "/bin/bash")))
+ (wrap-program
(string-append out "/bin/screenfetch")
- `("PATH" ":" prefix
- (,(string-append (assoc-ref %build-inputs "bc") "/bin:"
- (assoc-ref %build-inputs "scrot") "/bin:"
- (assoc-ref %build-inputs "xdpyinfo") "/bin"
- (assoc-ref %build-inputs "xprop") "/bin"))))
- (substitute* (string-append out "/bin/screenfetch")
- (("#!#f")
- (string-append "#!" (assoc-ref %build-inputs "bash")
- "/bin/bash")))))))
- (inputs
- `(("bash" ,bash)
- ("bc" ,bc)
- ("scrot" ,scrot)
- ("xdpyinfo" ,xdpyinfo)
- ("xprop" ,xprop)))
- (home-page "https://github.com/KittyKatt/screenFetch")
- (synopsis "System information script")
- (description "Bash screenshot information tool which can be used to
+ `("PATH" ":" prefix
+ (,(string-append (assoc-ref %build-inputs "bc") "/bin:"
+ (assoc-ref %build-inputs "scrot") "/bin:"
+ (assoc-ref %build-inputs "xdpyinfo") "/bin"
+ (assoc-ref %build-inputs "xprop") "/bin"))))
+ (substitute* (string-append out "/bin/screenfetch")
+ (("#!#f")
+ (string-append "#!" (assoc-ref %build-inputs "bash")
+ "/bin/bash")))))))
+ (inputs
+ `(("bash" ,bash)
+ ("bc" ,bc)
+ ("scrot" ,scrot)
+ ("xdpyinfo" ,xdpyinfo)
+ ("xprop" ,xprop)))
+ (home-page "https://github.com/KittyKatt/screenFetch")
+ (synopsis "System information script")
+ (description "Bash screenshot information tool which can be used to
generate those nifty terminal theme information and ASCII distribution logos in
everyone's screenshots nowadays.")
- (license license:gpl3))))
+ (license license:gpl3)))
(define-public nnn
(package