summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
commit961d2ee2695b38503b463d055e9c7edbcc0bf307 (patch)
tree82d9b40477a1d4d88e75a187b2b637a56751480b /gnu/packages/admin.scm
parent7cf79d7a51ff5dde4fc430fab2296b5f7de08953 (diff)
parentaebba13c0bef5a58697f1a9fe8337967cc01300f (diff)
downloadguix-patches-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar
guix-patches-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm30
1 files changed, 22 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 350cd541b7..63ee6dd53f 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
@@ -813,12 +813,17 @@ connection alive.")
(("^RELEASEVER=.*")
(format #f "RELEASEVER=~a\n" ,bind-release-version)))
#t))
- (add-before 'configure 'fix-bind-cross-compilation
- (lambda _
- (substitute* "configure"
- (("--host=\\$host")
- "--host=$host_alias"))
- #t))
+ ,@(if (%current-target-system)
+ '((add-before 'configure 'fix-bind-cross-compilation
+ (lambda _
+ (substitute* "configure"
+ (("--host=\\$host")
+ "--host=$host_alias"))
+ ;; BIND needs a native compiler because the DHCP
+ ;; build system uses the built 'gen' executable.
+ (setenv "BUILD_CC" "gcc")
+ #t)))
+ '())
(add-after 'configure 'post-configure
(lambda* (#:key outputs #:allow-other-keys)
;; Point to the right client script, which will be
@@ -3162,7 +3167,16 @@ late.")
version "/launchmon-v" version ".tar.gz"))
(sha256
(base32
- "0fm3nd9mydm9v2bf7bh01dbgrfnpwkapxa3dsvy3x1z0rz61qc0x"))))
+ "0fm3nd9mydm9v2bf7bh01dbgrfnpwkapxa3dsvy3x1z0rz61qc0x"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Fix build failure with GCC 7 due to a conversion error.
+ ;; Remove for versions > 1.0.2.
+ (substitute* "launchmon/src/linux/lmon_api/lmon_coloc_spawner.cxx"
+ ((" lmonpl = '\\\\0'")
+ " *lmonpl = '\\0'"))
+ #t))))
(build-system gnu-build-system)
(inputs
`(("mpi" ,openmpi)