summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-05 17:23:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-07 00:55:45 +0200
commit8e4d44ad390c2171e8ae212dea0ec93d6af278f1 (patch)
treef294af5ef7fa4426def53f5f8e1109c85bbddb07 /gnu/packages/admin.scm
parentee9c44c76752231ea40f2492304426f204f93a0e (diff)
downloadguix-patches-8e4d44ad390c2171e8ae212dea0ec93d6af278f1.tar
guix-patches-8e4d44ad390c2171e8ae212dea0ec93d6af278f1.tar.gz
gnu: Add cfm.
* gnu/packages/admin.scm (cfm): New public variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2963f3e049..8e43d8fe97 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -329,6 +329,38 @@ interface and is based on GNU Guile.")
#t)))
,@(package-arguments shepherd)))))
+(define-public cfm
+ (package
+ (name "cfm")
+ (version "0.6.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WillEccles/cfm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14gapia902f29wa4dlrrj8jcwcff9bfvyhjccw9ddy2gxx2g8wmr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; Keeping xdg-open optional avoids a size increase of 293%.
+ (delete 'configure)))) ; no configure script
+ (home-page "https://eccles.dev/cfm/")
+ (synopsis
+ "Simple terminal file manager with @command{vi}-inspired key bindings")
+ (description
+ "The Cactus File Manager (@command{cfm}) helps you manage your files
+visually from a text terminal. It aims to be simple and fast, with key bindings
+inspired by @command{vi}.")
+ (license license:mpl2.0)))
+
(define-public cloud-utils
(package
(name "cloud-utils")