summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-17 09:54:11 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-02-17 09:57:22 +0800
commit861ba5258399360a8f4c4e7cd08958f46d2c2b1e (patch)
treefb3cd8d37663c611364d8c9e8f707c133b5e3491 /gnu/packages/admin.scm
parent8fc36d82271946bf5e327b0f2feef9f65ce91701 (diff)
downloadguix-patches-861ba5258399360a8f4c4e7cd08958f46d2c2b1e.tar
guix-patches-861ba5258399360a8f4c4e7cd08958f46d2c2b1e.tar.gz
gnu: Add ttyload.
* gnu/packages/admin.scm (ttyload): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 77386d6033..282a513320 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -527,6 +528,42 @@ or via the @code{facter} Ruby library.")
(home-page "https://github.com/puppetlabs/facter-ng")
(license license:expat)))
+(define-public ttyload
+ (let ((revision "1")
+ (commit "f9495372801ce4b4dad98ad854203e694c31c1eb"))
+ (package
+ (name "ttyload")
+ (version (git-version "0.5.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lindes/ttyload")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ldb7a13b9v876c6cbrs78pkizj64drnqx95z5shfbwgpwfhr4im"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "ttyload" bin)))))))
+ (home-page "https://www.daveltd.com/src/util/ttyload/")
+ (synopsis "Console based color-coded graphs of CPU load average")
+ (description
+ "Show graphs for 1 minute, 5 minute, 15 minute load averages on the
+console.")
+ ;; This package uses a modified version of the "ISC License".
+ (license (license:non-copyleft "file://LICENSE")))))
+
(define-public htop
(package
(name "htop")