summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorlasnesne <lasnesne@lagunposprasihopre.org>2021-01-19 23:00:49 +0900
committerLudovic Courtès <ludo@gnu.org>2021-02-25 00:01:58 +0100
commit532406088a61fa629874ca993284d8fb4d67f819 (patch)
tree6e1a818de694748d15665fd0aadeb6deb90afe26 /gnu/packages/admin.scm
parente68ae7f00e2e9817dacb301a97289da68efed5a1 (diff)
downloadguix-patches-532406088a61fa629874ca993284d8fb4d67f819.tar
guix-patches-532406088a61fa629874ca993284d8fb4d67f819.tar.gz
gnu: solaar: Add missing dependencies for the GUI.
* gnu/packages/admin.scm (solaar)[propagated-inputs]: Add PYTHON-PYYAML, PYTHON-PSUTIL, PYTHON-XLIB, GTK+, and PYTHON-PYGOBJECT. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a506b978f5..cf27eea084 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3944,7 +3945,14 @@ cache of unix and unix-like systems.")
#t)))))
(propagated-inputs
`(("python-pygobject" ,python-pygobject)
- ("python-pyudev" ,python-pyudev)))
+ ("python-pyudev" ,python-pyudev)
+
+ ;; For GUI.
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-psutil" ,python-psutil)
+ ("python-xlib" ,python-xlib)
+ ("gtk+" ,gtk+)
+ ("python-pygobject" ,python-pygobject)))
(home-page "https://smxi.org/docs/inxi.htm")
(synopsis "Linux devices manager for the Logitech Unifying Receiver")
(description "This package provides tools to manage clients of the