summaryrefslogtreecommitdiff
path: root/gnu/packages/ada.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 13:34:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:14 -0400
commit74641c7f66bc18a29aa92777a9616415eed6661e (patch)
treea42c1725a55269c873880da76677aeafaed94daa /gnu/packages/ada.scm
parent787a026f003fad544a81d3f13901603ee4e2469c (diff)
downloadguix-patches-74641c7f66bc18a29aa92777a9616415eed6661e.tar
guix-patches-74641c7f66bc18a29aa92777a9616415eed6661e.tar.gz
gnu: Remove python2-langkit.
* gnu/packages/ada.scm (python2-langkit): Delete variable.
Diffstat (limited to 'gnu/packages/ada.scm')
-rw-r--r--gnu/packages/ada.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/ada.scm b/gnu/packages/ada.scm
index a3bba245ec..ea3e9c365b 100644
--- a/gnu/packages/ada.scm
+++ b/gnu/packages/ada.scm
@@ -149,32 +149,3 @@ Ada system. Being an interpreter, it does not implement most representation
clauses, and thus does not support systems programming close to the machine
level.")
(license license:gpl2+)))
-
-(define-public python2-langkit
- (let ((commit "fe0bc8bf60dbd2937759810df76ac420d99fc15f")
- (revision "0"))
- (package
- (name "python2-langkit")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AdaCore/langkit")
- (commit commit)))
- (sha256
- (base32
- "1abqgw2p8pb1pm54my5kkbbixfhc6l0bwajdv1xlzyrh31xki3wx"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python2-docutils python2-enum34 python2-funcy python2-mako))
- (arguments
- `(#:python ,python-2
- #:tests? #f)) ; Tests would requite gprbuild (Ada).
- (synopsis "Semantic analysis tool generator in Python")
- (description "@code{Langkit} is a tool whose purpose is to make it easy
-to create syntactic and semantic analysis engines. Write a language
-specification in our Python DSL and Langkit will generate for you an
-Ada library with bindings for the C and Python programming languages.")
- (home-page "https://github.com/AdaCore/langkit/")
- (license license:gpl3+)))) ; and gcc runtime library exception