summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /gnu/packages/acl.scm
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index c2de62657f..b299e7d284 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -114,23 +114,23 @@
(modify-phases %standard-phases
(add-after 'unpack 'disable-tests
(lambda* (#:key outputs inputs #:allow-other-keys)
- ;; These tests operate on real files, but our tempfs does not support
- ;; ACLs
+ ;; These tests operate on real files, but our tmpfs does not support
+ ;; ACLs.
(substitute* "tests/test_acls.py"
(("( *)def test_applyto(_extended(_mixed)?)?" match indent)
- (string-append indent "@pytest.mark.skip(reason=\"guix\")\n" match)))
- #t))
+ (string-append indent "@pytest.mark.skip(reason=\"guix\")\n"
+ match)))))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "tests"))
- #t)))))
+ (invoke "pytest" "tests")))))))
(inputs `(("acl" ,acl)))
(native-inputs `(("python-pytest" ,python-pytest)))
(home-page "https://pylibacl.k1024.org/")
- (synopsis "POSIX.1e ACLs for python")
- (description "Python 3.4+ extension module that allows you to manipulate
-the POSIX.1e Access Control Lists present in some OS/file-systems
-combinations.")
+ (synopsis "POSIX.1e @acronym{ACLs, access control lists} for Python")
+ (description
+ "This Python extension module manipulates the POSIX.1e @acronym{ACLs,
+Access Control Lists} available on many file systems. These allow more
+fine-grained access control than traditional user/group permissions.")
(license lgpl2.1+)))