summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 16:28:42 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-15 17:30:56 +0200
commita9b8443cc530fbf404f86c215ed77b8baeb0d108 (patch)
tree3cac7d9fa99fea99c6bf404754f433ae5bd0fe05 /gnu/packages/acl.scm
parenta24c0f5b948b9ad6d268cdbfdedcb48a2cff1a13 (diff)
downloadguix-patches-a9b8443cc530fbf404f86c215ed77b8baeb0d108.tar
guix-patches-a9b8443cc530fbf404f86c215ed77b8baeb0d108.tar.gz
gnu: python-pylibacl: Do not return #t from custom phases.
* gnu/packages/acl.scm (python-pylibacl)[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index abeafeef88..518f5f2ea7 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -114,18 +114,17 @@
(modify-phases %standard-phases
(add-after 'unpack 'disable-tests
(lambda* (#:key outputs inputs #:allow-other-keys)
- ;; These tests operate on real files, but our tempfs does not support
- ;; ACLs
+ ;; These tests operate on real files, but our tmpfs does not support
+ ;; ACLs.
(substitute* "tests/test_acls.py"
(("( *)def test_applyto(_extended(_mixed)?)?" match indent)
- (string-append indent "@pytest.mark.skip(reason=\"guix\")\n" match)))
- #t))
+ (string-append indent "@pytest.mark.skip(reason=\"guix\")\n"
+ match)))))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "tests"))
- #t)))))
+ (invoke "pytest" "tests")))))))
(inputs `(("acl" ,acl)))
(native-inputs `(("python-pytest" ,python-pytest)))
(home-page "https://pylibacl.k1024.org/")