summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-15 16:41:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-15 16:41:02 +0100
commit4403030b7de2485dbeb6ee54c56551a2bd2b5244 (patch)
tree27023428d199314536b729f1757a8885309fdc80 /gnu/packages/acl.scm
parent058ad040d64f873ffb9bb4d72166dae9f970b368 (diff)
downloadguix-patches-4403030b7de2485dbeb6ee54c56551a2bd2b5244.tar
guix-patches-4403030b7de2485dbeb6ee54c56551a2bd2b5244.tar.gz
gnu: acl: Fix build failure.
* gnu/packages/acl.scm (acl)[arguments]: Add phase "ensure-no-mtimes-pre-1980".
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 7880e533da..ee17c94262 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,8 +48,20 @@
(build-system gnu-build-system)
(arguments
`(#:test-target "tests"
+ #:modules ((ice-9 ftw)
+ ,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
+ ;; XXX After repacking the sources the timestamps are reset to the
+ ;; epoch, which leads to a failure in gzipping the CHANGES file.
+ (add-after 'unpack 'ensure-no-mtimes-pre-1980
+ (lambda _
+ (let ((early-1980 315619200)) ; 1980-01-02 UTC
+ (ftw "." (lambda (file stat flag)
+ (unless (<= early-1980 (stat:mtime stat))
+ (utime file early-1980 early-1980))
+ #t))
+ #t)))
(add-after 'build 'patch-exec-bin-sh
(lambda _
(substitute* "test/run"