summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-25 16:19:06 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-25 16:19:06 +0200
commit2a552f1177fc79a66ba5ae53467556dfa3386b68 (patch)
treef3cd020fc101c848f630e5325e845ac688b101ae /gnu/packages/acl.scm
parenta7dc055bb5e07e716e929f8a906081fbe0422ad3 (diff)
downloadguix-patches-2a552f1177fc79a66ba5ae53467556dfa3386b68.tar
guix-patches-2a552f1177fc79a66ba5ae53467556dfa3386b68.tar.gz
gnu: gettext, attr, acl: Disable `check' phase twiddling when cross building.
* gnu/packages/gettext.scm (gettext)[arguments]: Disable `check' phase manipulations when (%current-target-system) is true. * gnu/packages/attr.scm (attr)[arguments]: Likewise. * gnu/packages/acl.scm (acl)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 14579e9ea9..54c9116baf 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -45,18 +45,30 @@
'configure 'patch-makefile-SHELL
(lambda _
(patch-makefile-SHELL "include/buildmacros"))
- (alist-replace
- 'check
- (lambda _
- (system* "make" "tests" "-C" "test")
+ ,(if (%current-target-system)
+ '%standard-cross-phases
+ '(alist-replace 'check
+ (lambda _
+ (system* "make" "tests" "-C" "test")
- ;; XXX: Ignore the test result since this is
- ;; dependent on the underlying file system.
- #t)
- %standard-phases))))
+ ;; XXX: Ignore the test result since this is
+ ;; dependent on the underlying file system.
+ #t)
+ %standard-phases)))))
(inputs `(("attr" ,attr)
- ("gettext" ,guix:gettext)
- ("perl" ,perl)))
+
+ ;; Perl is needed to run tests; remove it from cross builds.
+ ,@(if (%current-target-system)
+ '()
+ `(("gettext" ,guix:gettext)
+ ("perl" ,perl)))))
+ (native-inputs
+ ;; FIXME: Upon next core-updates, make gettext a native input
+ ;; unconditionally.
+ (if (%current-target-system)
+ `(("gettext" ,guix:gettext))
+ '()))
+
(home-page
"http://savannah.nongnu.org/projects/acl")
(synopsis