summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/acl.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
guix-patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
new file mode 100644
index 0000000000..1cba608c8c
--- /dev/null
+++ b/gnu/packages/acl.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages acl)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages attr)
+ #:use-module (gnu packages perl)
+ #:use-module ((gnu packages gettext)
+ #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public acl
+ (package
+ (name "acl")
+ (version "2.2.51")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/acl/acl-"
+ version ".src.tar.gz"))
+ (sha256
+ (base32
+ "09aj30m49ivycl3irram8c3givc0crivjm3ymw0nhfaxrwhlb186"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-cons-after
+ 'configure 'patch-makefile-SHELL
+ (lambda _
+ (patch-makefile-SHELL "include/buildmacros"))
+ (alist-replace
+ 'check
+ (lambda _
+ (system* "make" "tests" "-C" "test")
+
+ ;; XXX: Ignore the test result since this is
+ ;; dependent on the underlying file system.
+ #t)
+ %standard-phases))))
+ (inputs `(("attr" ,attr)
+ ("gettext" ,guix:gettext)
+ ("perl" ,perl)))
+ (home-page
+ "http://savannah.nongnu.org/projects/acl")
+ (synopsis
+ "Library and tools for manipulating access control lists")
+ (description
+ "Library and tools for manipulating access control lists.")
+ (license '(gpl2+ lgpl2.1+))))