summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-10-23 21:09:00 -0400
committerMark H Weaver <mhw@netris.org>2014-10-26 02:55:38 -0400
commit16755848fc7f446ba4572d3c36c9b1d50410e927 (patch)
treeff3edddfaa46ee3775240818598ee488b67f4d59 /gnu/packages/acl.scm
parente102df281248b27c4213e5aae15dd428a605f773 (diff)
downloadguix-patches-16755848fc7f446ba4572d3c36c9b1d50410e927.tar
guix-patches-16755848fc7f446ba4572d3c36c9b1d50410e927.tar.gz
gnu: acl: Install library and disable failing test suite.
Previously, this package was completely broken. It installed only binaries that failed to run for lack of the shared library. * gnu/packages/acl.scm (acl): Disable tests. Remove customized 'check' phase that ran tests and ignored errors. Remove 'perl' as input, needed only for tests. Replace 'install' phase with one that includes 'install-lib' target.
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm26
1 files changed, 9 insertions, 17 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index ef15022566..cbe14c98ae 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,27 +40,18 @@
"08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f ; FIXME: Investigate test suite failures
+ #:phases
(alist-cons-after
'configure 'patch-makefile-SHELL
(lambda _
(patch-makefile-SHELL "include/buildmacros"))
- ,(if (%current-target-system)
- '%standard-phases
- '(alist-replace 'check
- (lambda _
- (system* "make" "tests" "-C" "test")
-
- ;; XXX: Ignore the test result since this is
- ;; dependent on the underlying file system.
- #t)
- %standard-phases)))))
- (inputs `(("attr" ,attr)
-
- ;; Perl is needed to run tests; remove it from cross builds.
- ,@(if (%current-target-system)
- '()
- `(("perl" ,perl)))))
+ (alist-replace
+ 'install
+ (lambda _
+ (zero? (system* "make" "install" "install-lib")))
+ %standard-phases))))
+ (inputs `(("attr" ,attr)))
(native-inputs
`(("gettext" ,gnu-gettext)))