summaryrefslogtreecommitdiff
path: root/gnu/packages/abiword.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:28:07 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:40:25 +0300
commit64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98 (patch)
tree94a6305cb93edbe896ef713ab8ab9b0c53eed88c /gnu/packages/abiword.scm
parent9a1bfd68a95fa91d3c80c2b77e0d69540cd2e8a9 (diff)
downloadguix-patches-64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98.tar
guix-patches-64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98.tar.gz
gnu: abiword: Update to 3.0.4.
* gnu/packages/abiword.scm (abiword): Update to 3.0.4. [source](patches): Remove "abiword-black-drawing-with-gtk322.patch" patch. Delete merged to upstream patch hunks in "abiword-explictly-cast-bools.patch" patch. * gnu/packages/patches/abiword-black-drawing-with-gtk322.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove this.
Diffstat (limited to 'gnu/packages/abiword.scm')
-rw-r--r--gnu/packages/abiword.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index db9f1bb72c..2b65a02242 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,7 @@
(define-public abiword
(package
(name "abiword")
- (version "3.0.2")
+ (version "3.0.4")
(source
(origin
(method url-fetch)
@@ -55,10 +56,9 @@
(string-append "https://www.abisource.com/downloads/abiword/" version
"/source/abiword-" version ".tar.gz"))
(sha256
- (base32 "08imry821g81apdwym3gcs4nss0l9j5blqk31j5rv602zmcd9gxg"))
+ (base32 "1mx5l716n0z5788i19qmad30cck4v9ggr071cafw2nrf375rcc79"))
(patches
- (search-patches "abiword-explictly-cast-bools.patch"
- "abiword-black-drawing-with-gtk322.patch"))))
+ (search-patches "abiword-explictly-cast-bools.patch"))))
(build-system glib-or-gtk-build-system)
(arguments ;; NOTE: rsvg is disabled, since Abiword