summaryrefslogtreecommitdiff
path: root/gnu/packages/abiword.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-07 11:02:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-07 11:02:52 +0300
commit5eabbc3e9089caebf74e7ce3d924b3f239d8c010 (patch)
tree33b0185cb196c398d967e6f009157bf94fa449bf /gnu/packages/abiword.scm
parent435a0462be7f3a5144b6eb89d6642490eb52f405 (diff)
downloadguix-patches-5eabbc3e9089caebf74e7ce3d924b3f239d8c010.tar
guix-patches-5eabbc3e9089caebf74e7ce3d924b3f239d8c010.tar.gz
gnu: abiword: Add epub, goffice support.
* gnu/packages/abiword.scm (abiword.scm)[arguments]: Add "epub" and "goffice" to "enable-plugins" configure flag. [inputs]: Add goffice, libchamplain, telepathy-glib.
Diffstat (limited to 'gnu/packages/abiword.scm')
-rw-r--r--gnu/packages/abiword.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index cac4881f1f..eac06ee02e 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -63,12 +63,12 @@
(list
"--enable-clipart" ;; TODO: The following plugins have unresolved
"--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
- (string-append ;; wordperfect, psion, mathview, goffice, epub.
+ (string-append ;; wordperfect, psion, mathview.
"--enable-plugins="
"applix " "babelfish " "bmp " "clarisworks " "collab " "command "
- "docbook " "eml " "freetranslation " "garble " "gdict " "gimp "
- "google " "hancom " "hrtext " "iscii " "kword " "latex "
- "loadbindings " "mht " "mif " "mswrite " "opendocument "
+ "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
+ "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
+ "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
"openwriter " "openxml " "opml " "ots " "paint " "passepartout "
"pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
"wikipedia " "wmf " "wml " "xslfo"))
@@ -85,7 +85,9 @@
("fontconfig" ,fontconfig)
("fribidi" ,fribidi)
("glib" ,glib)
+ ("goffice" ,goffice)
("gtk+" ,gtk+)
+ ("libchamplain" ,libchamplain)
("libglade" ,libglade)
("libgsf" ,libgsf)
("libjpeg" ,libjpeg)
@@ -97,6 +99,7 @@
("ots" ,ots)
("popt" ,popt)
("readline" ,readline)
+ ("telepathy" ,telepathy-glib)
("wv" ,wv)
("zlib" ,zlib)))
(native-inputs