summaryrefslogtreecommitdiff
path: root/gnu/packages/abiword.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-03-28 19:59:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-06 23:15:59 +0300
commit0ea4079f345a3b1583ba5d55f83f1f947b9a12fd (patch)
treeb7b0b7fcac0317715b06dd373782ff88549459df /gnu/packages/abiword.scm
parent17946534a4d49f375530f0af80b797172066b1fc (diff)
downloadguix-patches-0ea4079f345a3b1583ba5d55f83f1f947b9a12fd.tar
guix-patches-0ea4079f345a3b1583ba5d55f83f1f947b9a12fd.tar.gz
gnu: abiword: Update to 3.0.1.
* gnu/packages/abiword.scm (abiword): Update to 3.0.1. [source]: Remove 4 patches. [arguments]: Disable tests. [inputs]: Add libxslt, replace gtk+-2 with gtk+. [native-inputs]: Add libtool. * gnu/packages/patches/abiword-link-plugins-against-backend.patch, gnu/packages/patches/abiword-no-include-glib-internal-headers.patch, gnu/packages/patches/abiword-pass-no-undefined-to-linker.patch, gnu/packages/patches/abiword-use-proper-png-api.patch: Remove files. * gnu-system.am (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/abiword.scm')
-rw-r--r--gnu/packages/abiword.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index c6f259a2dd..cac4881f1f 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages enchant)
@@ -41,7 +43,7 @@
(define-public abiword
(package
(name "abiword")
- (version "2.8.6")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
@@ -49,15 +51,11 @@
(string-append "http://abisource.org/downloads/" name "/" version
"/source/" name "-" version ".tar.gz"))
(sha256
- (base32 "059sd2apxdmcacc4pll880i7vm18h0kyjsq299m1mz3c7ak8k46r"))
+ (base32 "1ik591rx15nn3n1297cwykl8wvrlgj78i528id9wbidgy3xzd570"))
(patches
(list
(search-patch "abiword-wmf-version-lookup-fix.patch")
- (search-patch "abiword-no-include-glib-internal-headers.patch")
- (search-patch "abiword-explictly-cast-bools.patch")
- (search-patch "abiword-use-proper-png-api.patch")
- (search-patch "abiword-pass-no-undefined-to-linker.patch")
- (search-patch "abiword-link-plugins-against-backend.patch")))))
+ (search-patch "abiword-explictly-cast-bools.patch")))))
(build-system gnu-build-system)
(arguments ;; NOTE: rsvg is disabled, since Abiword
@@ -65,7 +63,7 @@
(list
"--enable-clipart" ;; TODO: The following plugins have unresolved
"--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
- (string-append ;; wordperfect, psion, mathview, goffice.
+ (string-append ;; wordperfect, psion, mathview, goffice, epub.
"--enable-plugins="
"applix " "babelfish " "bmp " "clarisworks " "collab " "command "
"docbook " "eml " "freetranslation " "garble " "gdict " "gimp "
@@ -73,14 +71,21 @@
"loadbindings " "mht " "mif " "mswrite " "opendocument "
"openwriter " "openxml " "opml " "ots " "paint " "passepartout "
"pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
- "wikipedia " "wmf " "wml " "xslfo"))))
+ "wikipedia " "wmf " "wml " "xslfo"))
+ ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
+ ;; assertion 'GDK_IS_SCREEN (screen)' failed
+ ;; GLib-GObject-CRITICAL **: g_object_get_qdata:
+ ;; assertion 'G_IS_OBJECT (object)' failed
+ ;; Manually starting the X server before the test phase did not help
+ ;; the tests to pass.
+ #:tests? #f))
(inputs
`(("boost" ,boost)
("enchant" ,enchant)
("fontconfig" ,fontconfig)
("fribidi" ,fribidi)
("glib" ,glib)
- ("gtk+" ,gtk+-2)
+ ("gtk+" ,gtk+)
("libglade" ,libglade)
("libgsf" ,libgsf)
("libjpeg" ,libjpeg)
@@ -88,6 +93,7 @@
("librsvg" ,librsvg)
("libwmf" ,libwmf)
("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
("ots" ,ots)
("popt" ,popt)
("readline" ,readline)
@@ -96,6 +102,7 @@
(native-inputs
`(("intltool" ,intltool)
("glib:bin" ,glib "bin")
+ ("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(home-page "http://abisource.org/")
(synopsis "Word processing program")