summaryrefslogtreecommitdiff
path: root/gnu/packages/abiword.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-09 09:56:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-09 09:56:35 +0300
commit07b0662754014f7ac8ab81ce6a8878d0cc206b19 (patch)
tree9871c544d0df23d847f2955d25b94098899f679a /gnu/packages/abiword.scm
parent3880537c7403c3677ec46e991da9d25ca542c64b (diff)
downloadguix-patches-07b0662754014f7ac8ab81ce6a8878d0cc206b19.tar
guix-patches-07b0662754014f7ac8ab81ce6a8878d0cc206b19.tar.gz
gnu: abiword: Remove wmf support.
* gnu/packages/abiword.scm (abiword)[arguments]: Remove 'wmf' from the list of enabled plugins.
Diffstat (limited to 'gnu/packages/abiword.scm')
-rw-r--r--gnu/packages/abiword.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index cf906c6ea4..02f132f6f0 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
@@ -62,7 +62,7 @@
(build-system glib-or-gtk-build-system)
(arguments ;; NOTE: rsvg is disabled, since Abiword
`(#:configure-flags ;; supports it directly, and its BS is broken.
- (list
+ (list ;; wmf was removed from Guix for security.
"--enable-clipart" ;; TODO: The following plugins have unresolved
"--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
(string-append ;; wordperfect, psion, mathview.
@@ -73,7 +73,7 @@
"latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
"openwriter " "openxml " "opml " "ots " "paint " "passepartout "
"pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
- "wikipedia " "wmf " "wml " "xslfo"))
+ "wikipedia " "wml " "xslfo"))
;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
;; assertion 'GDK_IS_SCREEN (screen)' failed
;; GLib-GObject-CRITICAL **: g_object_get_qdata: