summaryrefslogtreecommitdiff
path: root/gnu/installer
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-23 14:40:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 22:08:24 +0200
commit3a7504cbc490f74d9b9d0a3a461058c1d6cafbe6 (patch)
tree27acc54f7a462258a84162ae2be1a3974d7d680d /gnu/installer
parent44d0acfe92fda66acb00e20e11555f2ba153afbb (diff)
downloadguix-patches-3a7504cbc490f74d9b9d0a3a461058c1d6cafbe6.tar
guix-patches-3a7504cbc490f74d9b9d0a3a461058c1d6cafbe6.tar.gz
installer: Reorder file system type listbox.
Recommending ext4 over btrfs is probably ill-advised nowadays. See the regular bug reports about running out of /gnu/store directory entries, for which the documented fix then breaks booting with GRUB. Instead, just list regular file systems alphabetically. We can bikeshed bcachefs later ;-) Move second-class file systems like NTFS to their own section at the end of the list. * gnu/packages/package-management.scm (run-fs-type-page): Reorder the LISTBOX-ITEMS.
Diffstat (limited to 'gnu/installer')
-rw-r--r--gnu/installer/newt/partition.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/installer/newt/partition.scm b/gnu/installer/newt/partition.scm
index ea524eb4c3..70c11ed8ad 100644
--- a/gnu/installer/newt/partition.scm
+++ b/gnu/installer/newt/partition.scm
@@ -131,7 +131,11 @@ Be careful, all data on the disk will be lost.")
(run-listbox-selection-page
#:info-text (G_ "Please select the file-system type for this partition.")
#:title (G_ "File-system type")
- #:listbox-items '(ext4 btrfs fat16 fat32 jfs ntfs xfs swap)
+ #:listbox-items '(btrfs ext4 jfs xfs
+ swap
+ ;; These lack basic Unix features. Their only use
+ ;; on GNU is for interoperation, e.g., with UEFI.
+ fat32 fat16 ntfs)
#:listbox-item->text user-fs-type-name
#:sort-listbox-items? #f
#:button-text (G_ "Exit")