summaryrefslogtreecommitdiff
path: root/gnu/installer/newt.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-12-04 11:33:16 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-12-11 21:37:07 +0100
commit8361817bf693742757b096468198626f297bb09e (patch)
treefe2008436678b49cb81f66811345e0474da2bafe /gnu/installer/newt.scm
parent6ca66f641485cc5a06ba7d34b9c36b738ea1d654 (diff)
downloadguix-patches-8361817bf693742757b096468198626f297bb09e.tar
guix-patches-8361817bf693742757b096468198626f297bb09e.tar.gz
install: Discover local substitute servers.
* gnu/installer/substitutes.scm: New file. * gnu/installer/newt/substitutes.scm: New file. * gnu/local.mk (INSTALLER_MODULES): Add them. * po/guix/POTFILES.in: Add gnu/installer/newt/substitutes.scm. * gnu/installer/proxy.scm (with-silent-shepherd): Move to ... * gnu/installer/utils.scm: ... here. * gnu/installer/record.scm (<installer>)[substitutes-page]: New field. * gnu/installer/newt.scm (substitutes-page): New procedure, (newt-installer): register it. * gnu/installer.scm (installer-steps): Add "substitutes-page" step. * gnu/system/install.scm (%installation-services): Add avahi-service-type and enable substitute server discover in guix-service-type. [<name-service-switch>]: Set it to %mdns-host-lookup-nss.
Diffstat (limited to 'gnu/installer/newt.scm')
-rw-r--r--gnu/installer/newt.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/installer/newt.scm b/gnu/installer/newt.scm
index a1cbeca49a..4f7fc6f4dc 100644
--- a/gnu/installer/newt.scm
+++ b/gnu/installer/newt.scm
@@ -30,6 +30,7 @@
#:use-module (gnu installer newt page)
#:use-module (gnu installer newt partition)
#:use-module (gnu installer newt services)
+ #:use-module (gnu installer newt substitutes)
#:use-module (gnu installer newt timezone)
#:use-module (gnu installer newt user)
#:use-module (gnu installer newt utils)
@@ -101,6 +102,9 @@ problem. The backtrace is displayed below. Please report it by email to \
(define (network-page)
(run-network-page))
+(define (substitutes-page)
+ (run-substitutes-page))
+
(define (hostname-page)
(run-hostname-page))
@@ -130,6 +134,7 @@ problem. The backtrace is displayed below. Please report it by email to \
(locale-page locale-page)
(menu-page menu-page)
(network-page network-page)
+ (substitutes-page substitutes-page)
(timezone-page timezone-page)
(hostname-page hostname-page)
(user-page user-page)