summaryrefslogtreecommitdiff
path: root/gnu/installer/newt.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-05 14:57:28 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:24 +0100
commit69a934f23ae1bd7dda9ec269a6ce3012e13c9011 (patch)
tree676284660aa7c1f29d5379bbb17b84d627a10fcf /gnu/installer/newt.scm
parent47c94801656c7e9ddf1dcfe0189b48d7c57d0a1d (diff)
downloadguix-patches-69a934f23ae1bd7dda9ec269a6ce3012e13c9011.tar
guix-patches-69a934f23ae1bd7dda9ec269a6ce3012e13c9011.tar.gz
installer: Add partitioning support.
* gnu/installer.scm (installer-steps): Add partitioning step. * gnu/installer/newt.scm (newt-installer): Add partition-page field. * gnu/installer/newt/partition.scm: New file. * gnu/installer/parted.scm: New file. * gnu/installer/record (installer): New partition-page field. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new files. * po/guix/POTFILES.in: Add new files.
Diffstat (limited to 'gnu/installer/newt.scm')
-rw-r--r--gnu/installer/newt.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/installer/newt.scm b/gnu/installer/newt.scm
index 3192e55b86..9d9212173d 100644
--- a/gnu/installer/newt.scm
+++ b/gnu/installer/newt.scm
@@ -25,6 +25,7 @@
#:use-module (gnu installer newt locale)
#:use-module (gnu installer newt menu)
#:use-module (gnu installer newt network)
+ #:use-module (gnu installer newt partition)
#:use-module (gnu installer newt services)
#:use-module (gnu installer newt timezone)
#:use-module (gnu installer newt user)
@@ -81,6 +82,9 @@
(define (user-page)
(run-user-page))
+(define (partition-page)
+ (run-partioning-page))
+
(define (services-page)
(run-services-page))
@@ -98,5 +102,6 @@
(timezone-page timezone-page)
(hostname-page hostname-page)
(user-page user-page)
+ (partition-page partition-page)
(services-page services-page)
(welcome-page welcome-page)))