summaryrefslogtreecommitdiff
path: root/gnu/installer.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-05 14:41:48 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:23 +0100
commitb51bde71a9385f4e81fbea258bfb9e8ff48be119 (patch)
treeebcd1332428ed202df0a911366c93cd1d149849b /gnu/installer.scm
parentc088b2e47f6675199f1ef545df7d04d4532e64e3 (diff)
downloadguix-patches-b51bde71a9385f4e81fbea258bfb9e8ff48be119.tar
guix-patches-b51bde71a9385f4e81fbea258bfb9e8ff48be119.tar.gz
installer: Add services page.
Add a page to select services, for now only desktop environments choice is available. * gnu/installer.scm (steps): Add services step. * gnu/installer/newt.scm (newt-installer): Add services-page field. * gnu/installer/newt/services.scm: New file. * gnu/installer/record.scm (installer): Add services-page field. * gnu/installer/services.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new files. * po/guix/POTFILES.in: Add new files.
Diffstat (limited to 'gnu/installer.scm')
-rw-r--r--gnu/installer.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 4a587eb35b..1b9aeaa217 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -229,16 +229,22 @@ selected keymap."
((installer-user-page current-installer))))
(configuration-formatter users->configuration))
+ ;; Ask the user to choose one or many desktop environment(s).
+ (installer-step
+ (id 'services)
+ (description (G_ "Services"))
(compute (lambda _
- ((installer-user-page current-installer)))))
+ ((installer-services-page current-installer))))
+ (configuration-formatter
+ desktop-environments->configuration))
- (installer-step
+ (installer-step
(id 'final)
(description (G_ "Configuration file"))
(compute
(lambda (result prev-steps)
((installer-final-page current-installer)
- result prev-steps)))))))
+ result prev-steps))))))))
(define (installer-program)
"Return a file-like object that runs the given INSTALLER."