summaryrefslogtreecommitdiff
path: root/gnu/build/svg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-25 00:58:26 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-25 01:21:28 +0200
commitffde82c9ecf99524220e463055f4f18c8c9e7a81 (patch)
tree79542b7085068a0f206e68a194acd53c8810b4a0 /gnu/build/svg.scm
parentd91025e3d0f7a30b38798bc4ef9c0f96d3f85db7 (diff)
downloadguix-patches-ffde82c9ecf99524220e463055f4f18c8c9e7a81.tar
guix-patches-ffde82c9ecf99524220e463055f4f18c8c9e7a81.tar.gz
system: grub: Use Guile-{RSVG,Cairo} instead of Inkscape + ImageMagick.
Based on a suggestion by Andy Wingo at <https://lists.gnu.org/archive/html/guix-devel/2015-08/msg00753.html>. * gnu/build/svg.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/system/grub.scm (svg->png): Add #:width and #:height. Rewrite to use (gnu build svg). (resize-image): Remove. (grub-background-image): Adjust accordingly.
Diffstat (limited to 'gnu/build/svg.scm')
-rw-r--r--gnu/build/svg.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/build/svg.scm b/gnu/build/svg.scm
new file mode 100644
index 0000000000..d9b909cd73
--- /dev/null
+++ b/gnu/build/svg.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu build svg)
+ #:use-module (srfi srfi-11)
+ #:export (svg->png))
+
+;; We need Guile-RSVG and Guile-Cairo. Load them lazily, at run time, to
+;; allow compilation to proceed.
+(module-use! (current-module) (resolve-interface '(rsvg)))
+(module-use! (current-module) (resolve-interface '(cairo)))
+
+(define* (downscaled-surface surface
+ #:key
+ source-width source-height
+ width height)
+ "Return a new rendering context where SURFACE is scaled to WIDTH x HEIGHT."
+ (let ((cr (cairo-create (cairo-image-surface-create 'argb32
+ width height))))
+ (cairo-scale cr (/ width source-width) (/ height source-height))
+ (cairo-set-source-surface cr surface 0 0)
+ (cairo-pattern-set-filter (cairo-get-source cr) 'best)
+ (cairo-rectangle cr 0 0 source-width source-height)
+ (cairo-fill cr)
+ cr))
+
+(define* (svg->png in-svg out-png
+ #:key width height)
+ "Render the file at IN-SVG as a PNG file in OUT-PNG. When WIDTH and HEIGHT
+are provided, use them as the dimensions of OUT-PNG; otherwise preserve the
+dimensions of IN-SVG."
+ (define svg
+ (rsvg-handle-new-from-file in-svg))
+
+ (let-values (((origin-width origin-height)
+ (rsvg-handle-get-dimensions svg)))
+ (let* ((surf (cairo-image-surface-create 'argb32
+ origin-width origin-height))
+ (cr (cairo-create surf)))
+ (rsvg-handle-render-cairo svg cr)
+ (cairo-surface-flush surf)
+ (let ((cr (if (and width height
+ (not (= width origin-width))
+ (not (= height origin-height)))
+ (downscaled-surface surf
+ #:source-width origin-width
+ #:source-height origin-height
+ #:width width
+ #:height height)
+ cr)))
+ (cairo-surface-write-to-png (cairo-get-target cr) out-png)))))
+
+;;; svg.scm ends here