summaryrefslogtreecommitdiff
path: root/gnu/build/file-systems.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-18 20:21:41 -0400
committerDavid Thompson <davet@gnu.org>2015-06-19 07:49:18 -0400
commit5fd77f3f437e9a648adc18efa8eb753b17915c9e (patch)
treef867149080221b21d9beb8740263a9bd8ac52fb0 /gnu/build/file-systems.scm
parent14a983c28ad0a06aeb90c9fc8ce8108fcf4f4eac (diff)
downloadguix-patches-5fd77f3f437e9a648adc18efa8eb753b17915c9e.tar
guix-patches-5fd77f3f437e9a648adc18efa8eb753b17915c9e.tar.gz
gnu: Make 'mount' interface in static Guile consistent with Guix API.
Rather than expecting a pointer, the version of 'mount' in guile-static-stripped now takes a string for the 'options' argument, just like the 'mount' procedure in (guix build syscalls). * gnu/packages/patches/guile-linux-syscalls.patch (mount): Expect a string or #f for 'options' argument. * gnu/build/file-systems.scm (mount-file-system): Use new 'mount' interface.
Diffstat (limited to 'gnu/build/file-systems.scm')
-rw-r--r--gnu/build/file-systems.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index dc99d60d3d..72c8bd59f3 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -286,16 +286,13 @@ run a file system check."
(when check?
(check-file-system source type))
(mkdir-p mount-point)
- (mount source mount-point type flags
- (if options
- (string->pointer options)
- %null-pointer))
+ (mount source mount-point type flags options)
;; For read-only bind mounts, an extra remount is needed, as per
;; <http://lwn.net/Articles/281157/>, which still applies to Linux 4.0.
(when (and (= MS_BIND (logand flags MS_BIND))
(= MS_RDONLY (logand flags MS_RDONLY)))
- (mount source mount-point type (logior MS_BIND MS_REMOUNT MS_RDONLY)
- %null-pointer))))))
+ (let ((flags (logior MS_BIND MS_REMOUNT MS_RDONLY)))
+ (mount source mount-point type flags #f)))))))
;;; file-systems.scm ends here