summaryrefslogtreecommitdiff
path: root/gnu/build/bootloader.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-12-05 12:59:15 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2017-12-15 11:52:38 +0100
commite22482038611a53a9d2b25df20363664cd91be2e (patch)
treeda53181cdbbe40b8035fdc577b0767e8055c9681 /gnu/build/bootloader.scm
parentacf54bca225b63f5b06e335a55045421c47bbd09 (diff)
downloadguix-patches-e22482038611a53a9d2b25df20363664cd91be2e.tar
guix-patches-e22482038611a53a9d2b25df20363664cd91be2e.tar.gz
bootloader: Factorize write-file-on-device.
* gnu/bootloader/extlinux.scm (install-extlinux): Factorize bootloader writing in a new procedure write-file-on-device defined in (gnu build bootloader). * gnu/build/bootloader.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file. * gnu/system/vm.scm (qemu-img): Adapt to import and use (gnu build bootloader) module during derivation building. * gnu/scripts/system.scm (bootloader-installer-derivation): Ditto.
Diffstat (limited to 'gnu/build/bootloader.scm')
-rw-r--r--gnu/build/bootloader.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/build/bootloader.scm b/gnu/build/bootloader.scm
new file mode 100644
index 0000000000..d00674dd40
--- /dev/null
+++ b/gnu/build/bootloader.scm
@@ -0,0 +1,37 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu build bootloader)
+ #:use-module (ice-9 binary-ports)
+ #:export (write-file-on-device))
+
+
+;;;
+;;; Writing utils.
+;;;
+
+(define (write-file-on-device file size device offset)
+ "Write SIZE bytes from FILE to DEVICE starting at OFFSET."
+ (call-with-input-file file
+ (lambda (input)
+ (let ((bv (get-bytevector-n input size)))
+ (call-with-output-file device
+ (lambda (output)
+ (seek output offset SEEK_SET)
+ (put-bytevector output bv))
+ #:binary #t)))))