summaryrefslogtreecommitdiff
path: root/gnu/bootloader
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-11-20 16:32:16 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-22 21:59:05 +0100
commit74e35e8c94193a03cb1db61934340540ce0884a3 (patch)
tree4e94ca14c1977c2661d6dd857fbd3d78990c783a /gnu/bootloader
parenteff8e0b4d9d4b818150f64e151227e03fdcb5aab (diff)
downloadguix-patches-74e35e8c94193a03cb1db61934340540ce0884a3.tar
guix-patches-74e35e8c94193a03cb1db61934340540ce0884a3.tar.gz
gnu: Add u-boot-pinebook.
* gnu/packages/patches/u-boot-pinebook-a64-update-dts.patch: New file. * gnu/packages/patches/u-boot-pinebook-syscon-node.patch: New file. * gnu/packages/patches/u-boot-pinebook-mmc-calibration.patch: New file. * gnu/packages/patches/u-boot-pinebook-video-bridge.patch: New file. * gnu/packages/patches/u-boot-pinebook-r_i2c-controller.patch: New file. * gnu/packages/patches/u-boot-pinebook-dts.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/bootloaders.scm (u-boot-pinebook): New exported variable. * gnu/bootloader/u-boot.scm (u-boot-pinebook-bootloader): New exported variable. * gnu/system/install.scm (pinebook-installation-os): New exported variable.
Diffstat (limited to 'gnu/bootloader')
-rw-r--r--gnu/bootloader/u-boot.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/bootloader/u-boot.scm b/gnu/bootloader/u-boot.scm
index b5fab14e14..1c6f322bc4 100644
--- a/gnu/bootloader/u-boot.scm
+++ b/gnu/bootloader/u-boot.scm
@@ -32,6 +32,7 @@
u-boot-nintendo-nes-classic-edition-bootloader
u-boot-novena-bootloader
u-boot-pine64-plus-bootloader
+ u-boot-pinebook-bootloader
u-boot-puma-rk3399-bootloader
u-boot-wandboard-bootloader))
@@ -168,6 +169,11 @@
(inherit u-boot-allwinner64-bootloader)
(package u-boot-pine64-plus)))
+(define u-boot-pinebook-bootloader
+ (bootloader
+ (inherit u-boot-allwinner64-bootloader)
+ (package u-boot-pinebook)))
+
(define u-boot-puma-rk3399-bootloader
(bootloader
(inherit u-boot-bootloader)