summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-13 15:24:57 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-14 11:50:58 +0200
commit3b758dd22d691964ebbc0ce9521508fbc397263a (patch)
tree1cda91428c542f33bbb57a92f2add725dff5f587 /etc
parent3cb5ae8577db28b2c6013b9d9ecf99cb696e3432 (diff)
downloadguix-patches-3b758dd22d691964ebbc0ce9521508fbc397263a.tar
guix-patches-3b758dd22d691964ebbc0ce9521508fbc397263a.tar.gz
etc: Add 'source-manifest.scm'.
* etc/source-manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it.
Diffstat (limited to 'etc')
-rw-r--r--etc/source-manifest.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/etc/source-manifest.scm b/etc/source-manifest.scm
new file mode 100644
index 0000000000..f96a5da6f7
--- /dev/null
+++ b/etc/source-manifest.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;; This file returns a manifest containing origins of all the packages. The
+;;; main purpose is to allow continuous integration services to keep upstream
+;;; source code around. It can also be passed to 'guix weather -m'.
+
+(use-modules (srfi srfi-1) (srfi srfi-26)
+ (ice-9 match) (ice-9 vlist)
+ (guix packages) (guix profiles)
+ (gnu packages))
+
+(define (all-packages)
+ "Return the list of all the packages, public or private, omitting only
+superseded packages."
+ (fold-packages (lambda (package lst)
+ (match (package-replacement package)
+ (#f (cons package lst))
+ (replacement
+ (append (list replacement package) lst))))
+ '()
+ #:select? (negate package-superseded)))
+
+(define (upstream-origin source)
+ "Return SOURCE without any patches or snippet."
+ (origin (inherit source)
+ (snippet #f) (patches '())))
+
+(define (all-origins)
+ "Return the list of origins referred to by all the packages."
+ (let loop ((packages (all-packages))
+ (origins '())
+ (visited vlist-null))
+ (match packages
+ ((head . tail)
+ (let ((new (remove (cut vhash-assq <> visited)
+ (package-direct-sources head))))
+ (loop tail (append new origins)
+ (fold (cut vhash-consq <> #t <>)
+ visited new))))
+ (()
+ origins))))
+
+;; Return a manifest containing all the origins.
+(manifest (map (lambda (origin)
+ (manifest-entry
+ (name (or (origin-actual-file-name origin)
+ "origin"))
+ (version "0")
+ (item (upstream-origin origin))))
+ (all-origins)))