summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2022-09-10 10:03:10 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-24 14:49:09 +0200
commitc8112f3bd95269ce4aca12dedbfe61bb6b37acae (patch)
tree04fb56e2d174d33c4d53212bb0509fcf5689c9a1 /doc
parent233cf9f0367e78562f07ac9885ed2cc6defe17e1 (diff)
downloadguix-patches-c8112f3bd95269ce4aca12dedbfe61bb6b37acae.tar
guix-patches-c8112f3bd95269ce4aca12dedbfe61bb6b37acae.tar.gz
system: images: Add wsl2 module.
* gnu/system/images/wsl2.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi ("System Images"): Document it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi13
1 files changed, 13 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 6c44c22a32..ba13ebf144 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -41476,6 +41476,8 @@ one or multiple partitions.
@item @code{tarball}, a tar.gz image archive.
+@item @code{wsl2}, a WSL2 image.
+
@end itemize
@item @code{platform} (default: @code{#false})
@@ -41842,6 +41844,17 @@ Build an image similar to the one built by the @code{hurd-image-type}
but with the @code{format} set to @code{'compressed-qcow2}.
@end defvr
+@defvr {Scheme Variable} wsl2-image-type
+Build an image for the @acronym{WSL2, Windows Subsystem for Linux 2}.
+It can be imported by running:
+
+@example
+wsl --import Guix ./guix ./wsl2-image.tar.gz
+wsl -d Guix
+@end example
+
+@end defvr
+
So, if we get back to the @code{guix system image} command taking an
@code{operating-system} declaration as argument. By default, the
@code{efi-raw-image-type} is used to turn the provided