summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-03 21:43:30 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-03 21:49:54 +0100
commitd388c2c435395aee61dc074023b1f218e6037545 (patch)
tree9b9016d2dea7bb708a20a571f5d48a3ec17bc3fb /configure.ac
parent1275baeba7bbee85a28766eb7307cf1690ec08d2 (diff)
downloadguix-patches-d388c2c435395aee61dc074023b1f218e6037545.tar
guix-patches-d388c2c435395aee61dc074023b1f218e6037545.tar.gz
build: Require GNU libgcrypt.
* guix/utils.scm (sha256): Remove Coreutils- and libchop-based implementations. * README: Update accordingly. * m4/guix.m4: New file. * configure.ac: Use `GUIX_ASSERT_LIBGCRYPT_USABLE'. Set and substitute `LIBGCRYPT_PREFIX'. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Pass `--with-libgcrypt-prefix=$(LIBGCRYPT_PREFIX)'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6d3d1482b4..cd07a54a3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,9 +65,11 @@ AC_ARG_WITH([libgcrypt-prefix],
[case "$withval" in
yes|no)
LIBGCRYPT="libgcrypt"
+ LIBGCRYPT_PREFIX="no"
;;
*)
LIBGCRYPT="$withval/lib/libgcrypt"
+ LIBGCRYPT_PREFIX="$withval"
;;
esac],
[LIBGCRYPT="libgcrypt"])
@@ -76,6 +78,10 @@ dnl Library name suitable for `dynamic-link'.
AC_MSG_CHECKING([for libgcrypt shared library name])
AC_MSG_RESULT([$LIBGCRYPT])
AC_SUBST([LIBGCRYPT])
+AC_SUBST([LIBGCRYPT_PREFIX])
+
+GUIX_ASSERT_LIBGCRYPT_USABLE
+
AC_CONFIG_FILES([Makefile
po/Makefile.in