summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-09 22:26:51 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-10 00:36:00 +0200
commit9c7dd33a48858b7cb3cc81a99ef84048d7584cdf (patch)
tree1c02a67876cbeda15da7b666193306588ee53154 /configure.ac
parentcf8f58b2afaaa9ac639804992061cb2ae03db582 (diff)
downloadguix-patches-9c7dd33a48858b7cb3cc81a99ef84048d7584cdf.tar
guix-patches-9c7dd33a48858b7cb3cc81a99ef84048d7584cdf.tar.gz
build: Make sure the user's Guile has all the required features.
* m4/guix.m4 (GUIX_ASSERT_GUILE_FEATURES): New macro. * configure.ac: Use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e98251b21b..61cee965b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,9 @@ if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
fi
+dnl Make sure we have a full-fledged Guile.
+GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])
+
AC_ARG_WITH([nix-prefix],
[AS_HELP_STRING([--with-nix-prefix=DIR], [search for Nix in DIR])],
[case "$withval" in