summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-08-17 10:41:27 +0200
committerLudovic Courtès <ludo@gnu.org>2012-08-17 10:41:27 +0200
commit3a310cc017c4bffbee8a6f37569145a593ac2912 (patch)
tree6b12926e76b238bd26a5aa4d9e3f2a444c799517 /configure.ac
parent93a0a8b3fdced4afe3ac2fb0783944c5d76cb360 (diff)
downloadguix-patches-3a310cc017c4bffbee8a6f37569145a593ac2912.tar
guix-patches-3a310cc017c4bffbee8a6f37569145a593ac2912.tar.gz
build: Add `--with-libgcrypt-prefix'; capture the path to libgcrypt.
* configure.ac: Add `--with-libgcrypt-prefix'. Substitute `LIBGCRYPT'. * Makefile.am (.scm.go): Pass $(LIBGCRYPT). * guix/utils.scm (%libgcrypt): New variable. (sha256): Use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aed8287bfd..821e746fe8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,23 @@ else
AC_MSG_WARN([Please use `--with-nixpkgs'.])
fi
+AC_ARG_WITH([libgcrypt-prefix],
+ [AS_HELP_STRING([--with-libgcrypt-prefix=DIR], [search for GNU libgcrypt in DIR])],
+ [case "$withval" in
+ yes|no)
+ LIBGCRYPT="libgcrypt"
+ ;;
+ *)
+ LIBGCRYPT="$withval/lib/libgcrypt"
+ ;;
+ esac],
+ [LIBGCRYPT="libgcrypt"])
+
+dnl Library name suitable for `dynamic-link'.
+AC_MSG_CHECKING([for libgcrypt shared library name])
+AC_MSG_RESULT([$LIBGCRYPT])
+AC_SUBST([LIBGCRYPT])
+
AC_CONFIG_FILES([Makefile
po/Makefile.in
guix-build])